Hello Guest it is May 07, 2021, 08:40:10 AM

Author Topic: phantom limit switch  (Read 10592 times)

0 Members and 1 Guest are viewing this topic.

phantom limit switch
« on: March 08, 2008, 12:41:20 AM »
Just finished our build on our first CNC router, trying to get it up and running and keep getting a limiit switch triggered stop. I have all limits hooked up through my campbell BOB and test out fine on the diagnostics page. But if you sit there and stare it for a while you see a limit mysteriously light up and instantly go back out. Any suggestions??

Also, I'm getting very poor movement (jerky and slow) from my motors regardless of Velocity and Accel settings. I'm using Gecko 201 and have 1.8degree stepper motors and have it set to 2000 steps per(10 tpi x 200 rev), to the best of my knowledge this is correct.  Any suggestions as to what the step pulse and DIR settings should be for the 201 drives??

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: phantom limit switch
« Reply #1 on: March 08, 2008, 03:18:31 AM »
Hi, Spiwrx

In General Configuration, Top Rt. Corner set the "De-bounce Interval" to 1000 for a start, (Helps with stray/spurious signal reduction).


Your Geckos are "10 micro step", Steps Per, In Motor Tunning should be 20000, (10 tpi x 200 stp-rev x 10 micro-stp = 20000).

In Ports & Pins, Motor Outputs, set the Dir & Steps to a "Checked".

If any axis runs backwards.

Opt. 1, Swap the wires on "one coil" (Phase A & Phase B) or (Coil A & Coil A-), Depending on how it's Marked.
 
Opt. 2, In Home & Limits, Set Reversed to "Checked" for the Axis.

The following steps are a short cut to Tuning Mach3, If you follow this, I think it will expedite your setup and understanding of mach3.

(Mach3 download defaults are a little confusing, Feed-Rate Setting Defaults to 6.0 and causes many to tune to this value).

Under "Operator" (Top row, Click On "Auto Calculator", This turns on a Pop-Up calculator).

Click on the Feedrate Number "Disp.Box" on "Program Run" Screen, Enter the value as described below, 150 or greater.

Your Velocity and Acceleration settings in Config, Motor Tuning set's your max speed's.

If the velocity top's out you need to turn up the "Kernel Speed" in Ports & pins and Re- Start Mach3. 

If you haven't setup/calibrated your Step's Per to inch or mm, You need to do that first. (Steps Per set to number of steps to move one Inch or MM)

On the Program Run page set the feed-rate to 150.00 or higher for fast machines, (This puts your feed-rate well above what your Max Velocity will be).

Hit the TAB key for pop-out Jog window, Set the Slow Jog Rate to 100 %, Jog Mode to "Cont.", (Axis will move as long as you hold the key down).

Now your Setup to use the axis arrow key's or mouse arrow button's to set up your velosity and acceleration, (Setting up vel/accl is a balancing act).

Set your vel. to 45 and accl to 15 for a start (Vel is typically 3 times higher than accl (more or less).

Increase the accl up till your servo trips or your steppers slip then back it off 10 % or so,

Then set the vel. up till it trips or slips also, Back it off 10% or so, Or till you think it's fast enough (Speed's can get scary on big servo or steppers).

Then after you get the max'es set, Your slower G01 with F speeds should be fine.

With G00 moves you'll get max speed for your Machine up to your "Velocity Setting".

This should get you pretty close, As your experience grows with Mach, You'll need to adjust accordingly.

Be Careful As You Go.

Hope this Helps, Chip
« Last Edit: March 08, 2008, 03:21:23 AM by Chip »
Re: phantom limit switch
« Reply #2 on: March 08, 2008, 04:34:48 PM »
Lot's of great info, I'll apply to the machine when I return to work monday.

Much appreciated...
Re: phantom limit switch
« Reply #3 on: March 11, 2008, 02:00:13 AM »
O.K. all that helped a great deal. I got my motors running and limits aren't acting up anymore.  However:

The motors are not very fast at all and run smooth as silk for a couple inches and then get jerky, stall and/or seem to slip. If I jog it a few times I get about the same result - runs smooth for a couple inches and then stalls or jerks. Manually all the axis run without much trouble so I'm doubtful of the motors or mechanics. I suspect I still have something set less than 100%.

I'm suspicious of the laptop it's running on as it sometimes is also choppy switching between programs or open windows.

Any more direction would be equally appreciated!

Re: phantom limit switch
« Reply #4 on: March 11, 2008, 05:41:15 AM »
I have this as well, on G00 the motor spins up fine then clunks and bangs horribly. I slowed it down and it stopped doing this, was it just going too fast or do i need to be cleverer? mine's quite a big machine so i could do with a decent fast-move rate.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: phantom limit switch
« Reply #5 on: March 11, 2008, 07:59:46 AM »
I have to respectfully disagree with Chip on the use of debounce in this caseĀ  :). Here you're not using debounce to debounce, you're using it to hide a problem instead of actually fixing it (In my view anyway). My starting guess would be that you may have a bad sig gnd. That could explain your bogus limit and your dodgy motion.

Ian
Re: phantom limit switch
« Reply #6 on: March 11, 2008, 11:03:53 AM »
Signals grounds are direct to my BOB which apparently has a floating ground as was told not to ground to case/earth.

xylotek /sound logic / campbell design BOB

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: phantom limit switch
« Reply #7 on: March 11, 2008, 11:58:34 AM »
Hi, Spiwrx

Do a "DriverTest" and see if your computer has vertical random spikes, If it dose there is a Optimize document bottom of the download page that may help.

Driver test is located in C:\Mach3 folder.

Check your laptop printer port output for 0 and 5 volts, Test one of the dir pins, Moving with arrow key one dir, should be 0 volts and the other dir should be 5 volts.

Some laptops only have 3.5 volt outputs that will not work very well at all. What's the CPU speed ?

As far as the De bounce setting, Mach's Default is 0 which is often unrealistic.

Just trying to get to a starting point hear, Guess I should have sed Turn them Off, First Post go figure, Just a starting point hear.

Sure it could be Allot of things, Bad Gng, Gnd loop, Wire Induction issues, Lose connection, Bad switch or contacts. 

On the Diagnostics Page do you see any flickering of the limit led's at all now ?

Let me now what you find.

Thanks, Chip
« Last Edit: March 11, 2008, 12:02:01 PM by Chip »
Re: phantom limit switch
« Reply #8 on: March 11, 2008, 12:27:06 PM »
Did, the driver test initially almost perfectly flat, Also my BOB has it's own power supply for the 5v drivers, I haven't tested the actually output but it's not being powered by the laptop. Changed the Kernel speed to no effective difference. 

The Debounce seemed to fix my limit switch issue, although I think that error is also a pin setting as the results are:
 x limits show on the m1++, m1--, m1 home and m2--
 y limits show m2++ and m2Home
 z limits show all m3

I'm sure I can figure the pin settings myself, I'm really more concerned about getting the motors to a better place. I'll try some of the optimizing...

BTW, on the Gecko drives should I be messing with the trim pot at all or not yet?? Not very clear in the gecko literature.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: phantom limit switch
« Reply #9 on: March 11, 2008, 12:27:11 PM »
Hi, BluePinnacle

Velocity and acceleration is a balancing act, Velocity to high or acceleration to steep/quick/aggressive can do it.

Using G00 moves or Mach's feed settings set higher than your velocity setting, Will help you find the balancing point.

Also do some X, Y diagonal moves when testing, You nay need to decrease  Velocity and acceleration a little more.

Hope this Helps, Chip