Hello Guest it is November 30, 2021, 02:17:34 PM

Author Topic: Rapid movement problem  (Read 6694 times)

0 Members and 1 Guest are viewing this topic.

Rapid movement problem
« on: February 24, 2008, 06:10:16 PM »
I've been working on a conversion for sometime now.  Anyway, I have my X axis semi-functional now but have a strange bug (I haven't bothered connecting my Y or Z axis unstil I get the bugs worked out).

Some info about the conversion:
Servos
USdigital 500 line encoders
Gecko Drives
Was a Wells Index CNC with a Bandit control.  Reusing the servo motors only.

PC:
Dell Inspiron Lap top, Pentium 3, 1.5gig
Opto-isolated breakout board

Here's the bug:
If I use the jog control (the thing that appears if you press tab) and either press the controls or hold the left/right arrow keys, the rapid runs great.  It sounds smooth and consistant like it did with my old controller.

If I run a rapid in MDI it runs terrible.  It runs very glitchy and staggers and sometimes will even throw the Gecko into a fault state.  Anything under 20 IPM runs very smooth.  I've been trying to tune the driver thinking it was the problem, but the fact that the Jog works so well leads me to believe it isn't the drive at all.

Any thoughts on this?

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Rapid movement problem
« Reply #1 on: February 24, 2008, 08:06:52 PM »
Hi, Chris64

This is a problem that is common, Mach default feed-rate is set to 6, The short of it is use MDI moves G00 X20 or so if you have the room.

Then adjust your Vel & Acceleration using G00 moves or hold down Shift key and arrow key's.

This should get you started in proper tuning.

Back in A-While, Chip
Re: Rapid movement problem
« Reply #2 on: February 24, 2008, 09:25:20 PM »
Hi, Chris64

This is a problem that is common, Mach default feed-rate is set to 6, The short of it is use MDI moves G00 X20 or so if you have the room.

Then adjust your Vel & Acceleration using G00 moves or hold down Shift key and arrow key's.

This should get you started in proper tuning.

Back in A-While, Chip

Can you elaborate on that.  I'm a little confused.  I would assume rapid move speeds would be established in the motor tuning section, correct?  I've tried hundreds of various settings with Vel & Accel and they're all about the same aside from the expected.  Slowing down acceleration didn't really improve anything, it just slowed down acceleration.  If I had it too high it would throw a fault on my driver (to be expected).  The velocity ended up working best right around 60 IPM, anything faster and it couldn't keep up with the software (also, to be expected).

I guess I'm confused also that it runs smooth with the jog control and very jumpy with a G0.
Re: Rapid movement problem
« Reply #3 on: February 24, 2008, 09:40:42 PM »
Hey Chris64,
When you use the tab flyout or use the arrow keys, the speed you are jogging is set by the % on the flyout.
If you hold SHIFT key and hit the arrows, you go to 100%..which is set in motor tuning.
MDI G0  is also your max in motor tuning.
Set the TAB flyout to 100% and see what you get.
Just a thought,
RC

Chip....Please correct me if I'm wrong. Thanks
« Last Edit: February 24, 2008, 11:12:57 PM by Overloaded »

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Rapid movement problem
« Reply #4 on: February 25, 2008, 03:08:18 AM »
Hi, Chris64

Had to go to the Airport (oil leak airplane,Work), Thanks RC, Your on the Money !!.

On the Program Run page set the feed-rate to 250.00 (This puts feed-rate well above what your Max Vel will be).

Hit the TAB key for pop-out jog window, Set the Slow Jog Rate to 100 %, Jog Mode to Cont.

Now your set to use the axis arrow key's or mouse axis dir. buttons to set vel & accl. settings, (Setting up vel/accl is a balancing act).

Set your accl to 15 and vel. to 45 for a start (Vel is typically 3 times higher than accl (more or less)).

Increase the accl up till your servo trips then back it off 10 % or so, Then set the vel up till it trips, Back it off 10% or so or till you think it's fast enough (Speed's can get scary).

If you haven't setup/calibrated your Step's Per to inch or mm, You need to do that first.

Getting Late, Then after you get the max'es set, Your slower G01 with F speeds should be fine.

Hope this Helps, Chip
Re: Rapid movement problem
« Reply #5 on: February 26, 2008, 01:05:12 AM »
OK...I tried a few things.  Everything was at 100% before except the MPG feedrate field directly below the "wheel/knob" looking thing.  It was set to 200%, but it didn't perform any different.

I also narrowed the definition of the problem more.  It seems that when you hold the keyboard it runs smooth.  Everything else runs in a pulsating type of motion.

Here's a video.
Smooth, while holding the arrow keys:
http://www.laptraffic.com/images/smooth.wmv

Pulsating, while holding the jog arrows using the mouse.  This is the same as when I do a G0 in the MDI field.  The video doesn't really do it justice of course.  It's a little difficult to hear over the phase converter unfortunately, but it has a distinctly pulsating motion in person.
http://www.laptraffic.com/images/notsmooth.wmv

Here's a screen shot of how it was configured during both of these tests

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Rapid movement problem
« Reply #6 on: February 26, 2008, 01:39:18 AM »
Hi, Chris64

Can you give us a video of the Diagnostic page while your running the code ?

Have you run the driver test, C:\Mach3\ folder. ? Look for large spikes, May need to optimize windows some.

http://www.machsupport.com/optimisation%20XP.txt

Is this computer dedicated to the mill. ?

Programs like QuickTime can cause un-stable pulses.

PM your Phone number if in US or do you have Skype.

Thanks, Chip
Re: Rapid movement problem
« Reply #7 on: February 26, 2008, 10:41:59 AM »
Hi, Chris64

Can you give us a video of the Diagnostic page while your running the code ?

Have you run the driver test, C:\Mach3\ folder. ? Look for large spikes, May need to optimize windows some.

http://www.machsupport.com/optimisation%20XP.txt

Is this computer dedicated to the mill. ?

Programs like QuickTime can cause un-stable pulses.

PM your Phone number if in US or do you have Skype.

Thanks, Chip
I'll run the driver test.
This is a dedicated laptop for the cnc.  It's XP pro with just a few things installed (office).  I'll make sure nothing starts up and follow the other suggested optimization idea's - I guess assuming I see spikes.
I can get a video of he diagnositc page for sure...I'll try to get that tonight.  Thanks for all the help.
Re: Rapid movement problem
« Reply #8 on: April 08, 2008, 09:04:48 PM »
OK, FINALLY I went in and optimized and ran it while watching the diagnostics page...here's what I found -

When running it with the arrow keys (and it runs nice and smooth) the Buffer load is 0 the whole time -
When running it with G codes, the Buffer load is up around 12% (fluctuates).

Does this indicate anything specific?  The only thing I had in the background was quicktime (I hate that program).  I did kill it and things did seem to perform slightly better - although that could be my imagination.

Offline Glenn

*
  •  129 129
    • View Profile
Re: Rapid movement problem
« Reply #9 on: April 08, 2008, 10:46:18 PM »
Chris64,
 Good that you got rid of quicktime, that should help,

it is common that the buffer load is 12-14% during G-code,
at least my laptop does the same thing, and it can run Mach.
Hope this helps!
Glenn
Don't assume anything.....it'll make a Manager out of U and Me!