Hello Guest it is September 16, 2019, 07:10:33 PM

Author Topic: Fast Jog but it skips on G-Code  (Read 5513 times)

0 Members and 1 Guest are viewing this topic.

Fast Jog but it skips on G-Code
« on: February 05, 2008, 12:52:08 PM »
???I have my motor tuning set to 50 ipm and it runs fine with the jog controls.  But when you run G-Code and the computer takes over, it skips steps on anything greater than 16 ipm.  There basically is no load on my router.  I'm just using a V-bit to carve in wood and only going 1/16" deep.  What is even more strange is that when I change my motor tuning to anything less than 50 ipm it skips when you jog.

Is there any way to get a faster cut speed?  I'd like to go up to at least 25 ipm.  I'm using HobbyCNC kit that includes the driver board and motors.

Thanks,
Clint

Re: Fast Jog but it skips on G-Code
« Reply #1 on: February 05, 2008, 01:26:50 PM »
Hi, Try increasing the drives acceleration time. The same thing happened when I set my machine up and this cured it.

If it doesn't, Try posting info on your power supply voltage and mechanical setup to help diagnose your problem.

Hope this helps.
Re: Fast Jog but it skips on G-Code
« Reply #2 on: February 05, 2008, 03:55:53 PM »
Thanks for your reply.  What is a good acceleration number?  I noticed that mine is set to 4.  My power supply is producing 33.4v to my steppers which are rated 3v 3A.  I was told that that was a good number.  I have HobbyCNC's 208 oz-in steppers.

Thanks,
Clint
Re: Fast Jog but it skips on G-Code
« Reply #3 on: February 05, 2008, 05:24:24 PM »
Hi, i'm not familiar with your setup but the voltage should be ok, try an accel value of 3, see what happens and if you get a good result increase in small increments.
Re: Fast Jog but it skips on G-Code
« Reply #4 on: February 05, 2008, 05:52:11 PM »
Thanks, will do.

Clint
Re: Fast Jog but it skips on G-Code
« Reply #5 on: February 06, 2008, 01:08:43 PM »
Just an update.  I set the acc. from 1 to 50 and it didn't seem to make any difference.  I set the ipm down to 45, the acc to 5 and the feed rate to 16.  I managed to run it without a skip for a couple of times.  Sure wish there was a way to up the feed rate.  Anyone have any suggestions.

Later,
Clint
Re: Fast Jog but it skips on G-Code
« Reply #6 on: February 06, 2008, 03:30:41 PM »
Hi Clint, I seem to have more questions than answers, let me get this straight. Your rapid speed is now set to 45 with accel set to 5, so your ramp-up time is 0.15 secs. At this setting you have run it without skipping.

Does it skip when on feed or rapids?

If the answer is at the very beginning of rapid moves during the ramp up period then you'll have to reduce the acceleration number. This is ok it'll just take a bit longer to get up to speed.

If it skips during the middle of a rapid move then basically the stepper cannot go that fast, you'll have to reduce the velocity.

A stepper motor on an axis can be made to go faster by,

Raising the drives voltage (make sure your drive can handle the voltage increase)
More powerful stepper motor. (If your existing motor is struggling to provide enough torque to overcome mechanical friction)
If your drive is uni-polar then changing to a bi-polar drive will increase the existing motors torque and speed.

If it skips during feeds then the problem could be,

Your computer is too slow (Computer's resources are at a minimum and has to do other tasks) I recommend no slower than 1200Mhz
Electrical noise (All your step and direction cables should be sheilded with only one end of the sheild connected to 0v)
A problem I havn't thought of. (Others chip in please to help this guy out)


Hope this helps.

Re: Fast Jog but it skips on G-Code
« Reply #7 on: February 06, 2008, 07:13:54 PM »
What happens is this.  When I set the motor tunings to 50ipm and acc. of 4 ( and I think 5 or whatever) I am able to use the jog controls without missing steps.  But when the computer runs the g-code, that is when it misses steps.  If you are able to jog at a given rate, why can't the computer run g-code at that rate, especially when there is no load on the steppers?

I guess that is my question.  When I set it to 45 (or 50) ipm and the feed rate to 16 ipm it seems to work, but I would like to cut faster than 16 ipm.

Thanks for your help.
Clint

Offline Chaoticone

*
  • *
  •  5,589 5,589
  • Precision Chaos
    • View Profile
Re: Fast Jog but it skips on G-Code
« Reply #8 on: February 06, 2008, 08:21:51 PM »
Are you rapid jogging and it doing good? Hold down the shift key and then jog. Another thing is this, Mach can change directions faster running code than you can with the keyboard.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline Chip

*
  • *
  •  2,056 2,056
  • Gainesville Florida USA
    • View Profile
Re: Fast Jog but it skips on G-Code
« Reply #9 on: February 06, 2008, 11:25:53 PM »
Hi, Clint

I think what maybe causing your problem is as follows,

Mach default's on start-up to F6 feed (Feedrate 6.00), If you use the Jog key's to setup Motor Tuning, Velocity & Acceleration, Thy will be way off.

On the Program Run Screen, Click on the Feed-rate DRO line, Type in 100 then "Enter", Feed-rate is now 100.00, Units/Min will show Your Velocity setting.

OK now check the % Jog setting, Press the TAB key for "Pop-out Jog Window", Set the Slow Jog Rate to 100 %.

Now set up your Velocity & Acceleration and then give your G-code a try.

Hope this Helps, Chip