Hello Guest it is July 04, 2022, 02:16:47 AM

Author Topic: Fast Jog but it skips on G-Code  (Read 6382 times)

0 Members and 1 Guest are viewing this topic.

Re: Fast Jog but it skips on G-Code
« Reply #10 on: February 07, 2008, 11:35:56 AM »
First off, thank you all for your help.  It is appreciated.  Here is the latest data I have.  Some things are better and some things are stranger.

Chip,  your advice helped a bunch.  The feed rate was set to 6 and the percentage to +5% or something like that.  I changed both of them to 100.  It ran better but it still wanted to skip.  I set it to 50 ipm on all axises and, here is the strange part, I had to set the acc. for Z to 1, Y to 2 and X to 3.  Then I set the feed rate in my g-code to 50.  It worked beautifully.  It was fast but the quality suffered a little.  Now when I change the feed rate to anything else than 50 it skips again.

Anyone have any more ideas.


Offline Chip

  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Fast Jog but it skips on G-Code
« Reply #11 on: February 07, 2008, 02:00:14 PM »
Hi, Clint

In motor tuning set the Step&Dir Pulse's to 5, This will give your stepper control more time to see the Pulse's

Setting up Vel. & Accl. is a balancing Act !!, It's primarily used for Rapid Moves (G00) Your F?? set's your Cut Speed's and will override Vel./Accl.

Set the Vel. Up to a speed that it start's lousing steps then back it down by about 10%, Do the same process for the Accl.

Use a distance that will allow you to see the top Vel. and then return to a stopped condition, G00 moves.

I think your accl. may be set to low.

Have you run the Driver Test, It's located in C:\Mach3 Folder, Run it and see what it shows.

If you have large spikes in the graph you may need to clear up Windows.

Thanks, Chip
Re: Fast Jog but it skips on G-Code
« Reply #12 on: February 11, 2008, 08:58:57 AM »
One last post (I hope).  Thank you all for your help.  After a lot of experimenting I have come to the conclusion that the problem isn't all Mach3.

Just a note for those who use the HobbyCNC package.  Set your board to 1/4 stepping.  Doesn't make sense but it works.  Using a 1/4-20 rod you end up with 16000 steps per inch.

Then I changed my motor tunings to 45 ipm and acc. of 10.  When I changed my settings to this it seems to work.

I have cut 3 complicated pieces and it never skipped.  Changed my feed rate from 30 to 16 and it still never skipped.  So thanks a lot everyone for your help.