Hello Guest it is April 01, 2023, 02:50:08 AM

Author Topic: PCI port card addressing woes  (Read 24839 times)

0 Members and 1 Guest are viewing this topic.

PCI port card addressing woes
« on: January 29, 2008, 07:31:51 AM »
Hello all

I'm at the end of my rope here.

In principle my machine should work, but I've had no luck in getting mach3 to talk to the PCI parallel port card I've got. It's one of these:


Mill: Pinnacle CNC vertical mill, 3-axis stepper, 4hp motor, controlled coolant, spindle, pneumatic brake, pneumatic drawbar. weighs about 2 tons  ;D
PC: no-name beige box, 900MHz Celeron, 512MB, no vices as such
Stepper controller: Routout 10-amp controller, works fine
port 1: LPT1 (onboard) works fine and sends the steppers up and down marvellously
port 2: Value twin PCI Parallel port adaptor, RS part number 449-2510, probably a cat in a bag as I've seen the same ones for £8 on Ebay and RS had £40 off me for it
Control/isolation: 9v control circuit, relayed/opto'd for safety, in-house design my m'self. works fine.

The PCI card installs smoothly enough and doesn't throw up any nasties on the way.

When I bring up mach3 it looks for the second port at 0x278, where it's supposed to be. This doesn't work, so I investigated further and went to Device manager to find the resources tab. LPT1 (onboard) has a resources tab, but LPT2 and LPT3 (PCI) do not. Looking through accessories>system tools>system information I can see a list of resources per device. I have the addresses for "multi I/O adapter" and the PCI slots themselves, but having plugged all of the address range start points into Mach3, I cannot get it to see the port at all, ever. I'm using auto-detect to look for a pin being switched on port 2. I've tried with and without my opto board, up to and including a bare cable shorting pins to ground.

looking at the PCI board, all the ground pins are indeed grounded so no issues there.

Is there a way round this? has anyone successfully wrangles one of these miserable cards into line?

Alternatively is there a known board that is better for the job? I've seen the Rogers ones mentioned, they seem very robust, and at the sort of price they are I'd be happy to go for one. I really need the extra inputs/outputs that a second port will give me. British distributors, anywhere?

Thanks in advance - any help appreciated.
Re: PCI port card addressing woes
« Reply #1 on: January 29, 2008, 08:09:09 PM »
Ok, Someone with a retail version of windows needs to contact Microsoft for support. Not the OEM version. I think it has something to do with the way Windows detects the M.B. MY 1G dual pIII just bit the bit. I want my 2nd port working again

 I have got two address numbers: one for multifunction I/O EC00. and one for parrallel port I/O E800. That cant be good????
I bet it can be fixed in the registry????? Just a guess, but Microsoft needs to fix us up. 866 234 2060.
Re: PCI port card addressing woes
« Reply #2 on: January 29, 2008, 08:13:22 PM »
It is only 59 bucks, and they just told me no charge if they cant fix it
Re: PCI port card addressing woes
« Reply #3 on: January 30, 2008, 09:18:41 AM »
Update! Success! sort of.

I tried a spare parallel port card that was lying around from someone else's computer, and it worked fine. The port addresses came up first time and everything. This one was based on a NetMos 9835 CV chipset and had two serial ports on a riser attached to it . Now, NetMos later turned into MosChip, so the drivers are available at http://www.moschip.com/data/products/NM/WinXP_2K_NT.zip . They installed fine and worked brilliantly with my isolating relay board.

unfortunately the board's owner wants it back despite offers of my left leg, wife etc. for it. An apparently identical one is available from Digital-systems.co.uk for £7.18 (stock code 26006) plus delivery so I'll have two here on Friday to play with. hopefully these will do as well. Either way, I'll be back in to tell you all about it. probably quite loudly...

As to the previous parallel card I had off RS, i think they want a little talking to for selling junk like this for that sort of price.
Re: PCI port card addressing woes
« Reply #4 on: January 31, 2008, 03:51:38 PM »
What operating system are you working with?  I'm having a heck of time trying to get a new computer with no parallel port to work with an add on board. I have two boards, one by SIIG and the other by PCI which sounds just like the one you ordered.  My board has NM9735 CV chipset.  But would not work.  I'm running Vista operating system.  The tech support at SIIG said that their board would not work, no way of addressing the legacy address.

SIIG CyberParallel Dual

Re: PCI port card addressing woes
« Reply #5 on: January 31, 2008, 04:43:53 PM »
i'm usiing  xp pro, i won't touch vista with a bargepole especially anything relying on low-level or time critical operations. now, i haven't used a 9735 chipset but i imagine it should perform pretty much the same as the one i was using, in xp at least.  if vista doesn't handle physical addressing in the same way as xp then you may be a bit stuck - there is a whole forum on vista compatibility. i won't be reading it until somebody not from redmond says anything nice about vista which doesn't involve desktop effects.

for my next trick i'm going to have to build a charge-pump safety board, since the lpt makes the relays snap on and off when the computer wakes up and coughs, and i don't want the spindle jumping about and the coolant jizzing all over, etc.
Re: PCI port card addressing woes
« Reply #6 on: January 31, 2008, 09:00:11 PM »
I am using the same 9835 netmos pci card, and it wont work for me, the drivers are the same for all metmos cards 9835, 9735 ect? this card worked with my 3k system that started missing. with 2k the address came up as 278m what address did you use? the multifunction card address or the plt2,3 address?
Re: PCI port card addressing woes
« Reply #7 on: February 01, 2008, 04:34:59 AM »

A lot of the I/O cards use the same driver package - As to exactly which drivers are installed i'm not sure. i just unpacked the .ZIP file to a flash drive and aimed the windows installer at it; off it toddled and installed the card. The port address was taken from Device Manager - just look up LPT2, properties, resources, and there's a box showing several hexidecimal input/output ranges , ie

18F - 194
455 - 48A

Copy the first, lowest address from this list (18F for this one, yours will be different) and pop it in Mach3's port address for LPT2, then click Apply. I note with some displeasure that changing the address does not by itself enable the apply button - to do this, uncheck and recheck the "enable port 2" tickbox, then click Apply as usual.

As to this business with some parallell cards not displaying a Resources tab ... I'm not sure but they may use some sort of emulation to allow printing but very little else. I think all told they're not worth the bother and should be avoided, I was looking for a proper address for mine in the depths of the registry and all sorts of other unholy places, it wasn't there.

Is there/should we start a thread solely devoted to cards or chipsets that we know behave themselves well with mach3?
Re: PCI port card addressing woes
« Reply #8 on: February 04, 2008, 05:46:03 AM »
I worked on mine again today, I am still baffled.
Q? Did you hook up your lp2 card to a device first? Is your enable plug and play device checked on? Did you manually set your card to lpt2? mine comes up as lpt3, but i change it. My lowest hexidecimal address is in the programs, acc, sys tool, sys info, hardware, i/O area: And it is E080-E08f. but in device manager it says ec00. Is my card not compatible????? Have you tried the   other cards you purchased? ty for the help.

I am checking my pins for voltage change with enable1,2,3.

I get no change at all. 17 is at low voltage and 2-9, 14,16 are 5.10. It must be an addressing issue. i think I am going to hook it up to a scanner, or printer next.

Offline Hood

  •  25,835 25,835
  • Carnoustie, Scotland
    • View Profile
Re: PCI port card addressing woes
« Reply #9 on: February 04, 2008, 06:06:53 AM »
You dont need to change it from Lpt3, all Mach needs is an address and it doesnt matter whether Windows says its Lpt1, 2, 3 ....50 OR whatever. All you are doing is asigning the address of your card as port2 in Mach, not Lpt2. Hope you follow what I mean.
Have you tried entering E080 or EC00? Maybe the reason you are seeing two different addresses is because you are changing it from Lpt3 to Lpt2.