Hello Guest it is August 17, 2019, 07:26:41 PM

Author Topic: Joging Problem  (Read 4360 times)

0 Members and 1 Guest are viewing this topic.

Joging Problem
« on: January 22, 2008, 12:20:19 AM »

I have Mach3 and I need help for Jogging .

 When I jog X or Y or Z any of (3 axes ) will move then slow  down almost stop jogging   then move again with a  maximum speed .and  if I reverse the Jogging I have the same  .also if  I use G00 for any axes  I have the same Problem .
When I install the older release .I don't have this Problem , this only with new release.

Please if any one can help me .to get smooth movement with new MACH3 release.


Saleh

Offline TonyP

*
  •  132 132
    • View Profile
Re: Joging Problem
« Reply #1 on: January 22, 2008, 06:27:10 AM »
Saleh,
Have you got backlash enabled? If so try turning it off. I've had something similar after upgrades. Sometimes even turning it off then back on again will sort things out.

Tony

Offline jimpinder

*
  •  1,233 1,233
  • Wakefield, West Yorks, UK
    • View Profile
Re: Joging Problem
« Reply #2 on: January 22, 2008, 06:38:35 AM »
AS Tony says - make sure backlash if off and try again - BUT - the problem will return when you turn backlash back on.

Backlash on Mach3 is a seperate movement on all the axis. It appears that the computer says - move x  - that is a different way to before - stop - put backlash on - stop - carry on with the move. Also in the backlash configuration, you can put in different speeds - and these seem to bear no relation to your traverse speed.

The result is, if you jog one way, then the other, the axis stops and starts four times instead of the anticipated once. Having said that it is accurate to less than a thousanth of an inch.
Not me driving the engine - I'm better looking.

Offline TonyP

*
  •  132 132
    • View Profile
Re: Joging Problem
« Reply #3 on: January 22, 2008, 06:54:44 AM »
Depends what the settings are in backlash. I have 0.18 mm and 30% set on my lathe & it seems to work fine - apart from the little ritual after every upgrade.
Several people have had the problem, but not everybody. Might be something to do with an imperial/ metric changeover after upgrade. It almost seems that toggling the function sorts it out. Obviously you would do a 'save settings' after getting it working.



Tony
Re: Joging Problem
« Reply #4 on: January 23, 2008, 03:44:18 PM »
Thank you Tony

I  disabled the  backlash   and  now is working .


Saleh,
Re: Joging Problem
« Reply #5 on: February 07, 2008, 09:57:06 AM »
If I disable the backlash how do I compensate for that?
I have the same problem in my syil super x3.

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Joging Problem
« Reply #6 on: February 07, 2008, 10:26:18 AM »
Try this, In general config. top center is a box, shuttle accel. Try setting this number to around .05-.1 and set your backlash speed to 200% in the backlash set up. You may have to play with these numbers to get it the way you want, but should work.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Joging Problem
« Reply #7 on: February 07, 2008, 11:47:55 AM »
Hey Brett,
Can you briefly describe the function of the Shuttle Wheel Accel setting ?
Is it an acceleration rate for jogging that is independent from the motor tuning settings ?
Thanks,
RC

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Joging Problem
« Reply #8 on: February 07, 2008, 03:52:43 PM »
Art has said,

nope. Shuttle Decel is identical to normal jog decel.
[2:01:24 PM] Art Fenerty says: Exact same code.

I don't know where it comes into play with respect to backlash tuning, but it does.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!