Hello Guest it is October 26, 2021, 10:45:13 AM

Author Topic: Problem zeroing to part  (Read 6670 times)

0 Members and 1 Guest are viewing this topic.

Problem zeroing to part
« on: January 20, 2008, 12:22:17 AM »
Hi All,
I'm new to MACH3 and recently received the program with the purchase of my new Taig CNC mill.
I'm having a problem zeroing the machine to my stock.
I created a test part in Rhino3D and generated the tool paths with RhinoCAM.
The test part was a simple 1"X1"X1" cubic stock that the mill had to round the edges of.
I posted the gcode, homed the machine coordinates and jogged to the stocks top, left, front corner, then zeroed the three axis's.
Now, here's where it gets confusing. First off, the cross hairs don't display on the edge where I jogged and zeroed. Instead, they display about 3/16ths into the stock from the front edge and left edge. I expected the cross hairs to appear exactly where I jogged and positioned on the stock and where it showed on the display but when I click the regenerate toolpath, it wasn't on that edge.
After playing around a little I decided to try positioning the tool at that 3/16th offset position and ran the operation.
The tool went along a path well outside the the actual stock.. following a path that appeared almost twice the size of the actual piece in the vise. The job eventually failed, obviously.. but I have not been able to understand why MACH is doing this.
Has anyone experienced this? Is this by design? I went back and generated a few other test parts, ranging from 2 inch square, 1X3 rectangles, etc.. they all did the same thing. All zeroed in about 3/16th  right in the X and deep in the Y.
Any suggestions are welcome.


Offline Chip

  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Problem zeroing to part
« Reply #1 on: January 20, 2008, 02:09:56 AM »
Hi, Michael

It could be allot of thing's, Use the REPLY Button and attach your G-Code Fie.

Did you get a startup XML file for the Mill, And setup/startup instruction's.?

Your RhinoCAM may be posting code for a larger Tool Diameter than your using. ?

On the MDI Page, Click on the Input Line, Type G01 X1 F10 Enter, Did the X axis move 1 inch. ?

Steps Per in Motor tuning may be set wrong.

Just a Start.

Let US  Now, Chip
Re: Problem zeroing to part
« Reply #2 on: January 20, 2008, 08:30:05 AM »
Hi Chip,
Thanks for the reply.. I have tried quite a few things already because, I agree with you.. this could be lots of different things!
I did receive an XML file from Kurt with the Taig. I did use a TAIG post processor out of Rhino, but it could need tweeking.
That XML file changes the motor tuning "Steps Per" setting to 8000 which I though was allot. Personally, I thought it was an issue with the TAIG XML file so I reverted to the orignial file and simulated.. but it did the same thing.
The Gcode is some 3000 lines and I don't know how to actually attach the whole file, aside from pasting it into this reply.
I'll spare you that agony.. .I'll include the first few lines, as this does the same thing within the program too.
Thanks again for your help!


Re: Problem zeroing to part
« Reply #3 on: January 20, 2008, 10:59:31 AM »
Just a quick update to this... I decided to give it another run this morning. I ignored the crosshairs indicated in MACH.. I just zeroed the machine on the high Z, left, front corner of the stock and ran the program to see the outcome. The part is definitely being cut to size.. however, the machine still starts well outside the 1"X 1" stock. Almost as if it thinks the stock is say.. 2 inches.
I guess it's not the end of the world but why waste the energy and time cutting air!
I'm using a 3/16 tool, which the program does identify when it reads the T1 code, so what would make it cut so far outside the boundaries of the specified stock?
Again, I'm new, so please suggest even the most obvious or ridiculous possibilities.  ;D
On a side note, MACH is occasionally stopping abruptly, returning an error that implies it reached a limit switch.. even though it's above the stock and very shallow in a cut. 50% of the time, I can resume without issue, the other 50%, it gouges the part, ruining the project. At least it's only pine so my tools not taking a beating. :D Anyone know why this occurs?
Thanks again!

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Problem zeroing to part
« Reply #4 on: January 20, 2008, 11:17:25 AM »
Yes your tool is being taken into account by your code, therefore your toolpath will be half the distance of your cutter outside of the part. The actual corner of your part will be 0,0 but the toolpath will be 3/32 outside of that. If you hand coded to do a 1 inch square and just did
G0 X0 Y0 Z0
G1 X1 F20
G1 Y1
G1 X0
G1 Y0

You would end up with a cross hair on your  toolpath but the part you cut would be 3/8 undersize.

Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Problem zeroing to part
« Reply #5 on: January 20, 2008, 11:21:17 AM »
On your sidenote, sounds like your limits may be noisy, try increasing the debounce to 2000 and see if it helps, if it does then reduce it until you hit problems again. The reason sometimes you gouge is because when the limit is triggered Mach stops everything but you will have a varying amount of momentum on your axis (depending how fast its going when the limit is triggered) so sometimes it will stop almost instantly and when you resume it will carry on OK. However if the axis carries on slightly then Mach doesnt know that and starts cutting upon the resume but is in the wrong location and so gouges.
« Last Edit: January 20, 2008, 11:25:38 AM by Hood »
Re: Problem zeroing to part
« Reply #6 on: January 20, 2008, 12:17:23 PM »
Morning Hood,
You make good points. The gouging issue certainly makes sense and I will adjust the debounce input signals to see if that helps. A quick looks shows a current setting of zero.
On your point about the tool compensation, sounds right to me, except the part is coming out to the correct size +/- 1/32.. but the toolpath is well outside of the 3/32 half tool diameter. I would estimate at least 0.5" outside. When I zero the part, I am doing so at the center of the tool, trying to compensate for the expected path. Should  I not be doing that?
I'm still playing around with different things, trying to familiarize myself but I am going to try just moving X and Y an inch at a time as Chip suggested and see if maybe a motor needs to be adjusted, though.. the fact that the finished part is the right size makes me think, the motors are fine as well.
The only real issue seems to be the stock size difference from what Rhino thinks an inch is and what Mach thinks an inch is.
Thanks again everyone, really.
Helps allot!


Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Problem zeroing to part
« Reply #7 on: January 20, 2008, 12:26:13 PM »
You are zeroing correctly, your cutter centre is where you want  the 0,0 position of your partto be. If you zero off a bit all that will happen is Mach will start cutting off that amount and if your stock is tight on size you will miss it. Dont think there is anything wrong with your motors or tuning as you say parts come out right.
Have you actually jogged from the 0 0 point to the toolpath and looked in Machs DROs to see how far its travelled?
To attach your code you can go to the full reply form and using the additional options button.
Re: Problem zeroing to part
« Reply #8 on: January 20, 2008, 01:08:42 PM »
Okay, I feel kinda stupid now... I went back to the drawingboard... literally... to generate new toolpaths in RhinoCAM and measured the poolpaths on the grid. They measure 1.75" from X- to X+.  ::)
I guess the machine and MACH were indeed doing exactly what I asked then to. DUH!
So I will have to bring that up on Rhino's Discussion board.

Also, I ran into another limit failure. I took that opportunity to change the debouce settings. I wasn't sure which option to increase to 2000 (Debounce Interval or Index Debounce) so I did both. But it did occur again. And again for seemingly no reason.. no obstructions or deep cutting far from any soft limits.
Should I increase it more unitil it stops, if ever,  and which setting exactly should I be adjusting?

Awesome advise!!
Thanks again!


Offline Hood

  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Problem zeroing to part
« Reply #9 on: January 20, 2008, 01:16:46 PM »
The Index debounce is for the Index pulse for Spindle speed so it is the Debounce Interval that you should be adjusting for noisy limits. You could try increasing further but if 2000 isnt helping then I think it would be best to resolve the problem by checking the wiring, using shielded cable if it isnt already, by using different switches. Do you know which limit is triggereing? it could just be one bad switch. You could remove one switch at a time from your setup and see if you can pinpoint which one it is then you have a starting point for finding out why its happening.