Hello Guest it is May 08, 2021, 04:03:49 PM

Author Topic: Mach 3 on lap top wont operate  (Read 15137 times)

0 Members and 1 Guest are viewing this topic.

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #10 on: November 25, 2007, 05:00:20 PM »
Hi, Al

In Ports & pins, Motor Outputs, Did you miss the Port settings to the far right.

Is Ports & pins, Is the port#1 set to 0x378 default, May be a different address ?

Thanks, Chip
Re: Mach 3 on lap top wont operate
« Reply #11 on: November 25, 2007, 05:06:49 PM »
Yes, the port setting is 0x378. How can I tell what the correct port address should be ?
Al
Re: Mach 3 on lap top wont operate
« Reply #12 on: November 25, 2007, 05:16:27 PM »
In the Device manager it shows 0378-037A and sys it is working properly.
Do I need to tweek something here ?
Al

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #13 on: November 25, 2007, 05:16:39 PM »
Nope 0378 sounds like the correct address, strange how its not working.
Hood
« Last Edit: November 25, 2007, 05:18:19 PM by Hood »

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #14 on: November 25, 2007, 05:19:05 PM »
Can you post your xml file and we can have a look and see if we notice anything untoward.
Hood
Re: Mach 3 on lap top wont operate
« Reply #15 on: November 25, 2007, 05:26:34 PM »
Hood, I can't for the life of me remember how to post a file here. Can you help me ?
Al
Re: Mach 3 on lap top wont operate
« Reply #16 on: November 25, 2007, 05:39:01 PM »
This should be the .xml file.

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #17 on: November 25, 2007, 05:40:25 PM »
You will need to copy your xml to your desktop (or any location other than the Mach3 folder) and rename it to something like allanjs.xml   This is because the standard Mach3.xml wont post here as it has already been posted and the forum will only allow a file to be posted once.
Ok now on to posting it, use the full reply page by hitting the reply button, then choose additional options and browse to your renamed xml and it should post ok.
Hood

Offline Hood

*
  •  25,838 25,838
  • Carnoustie, Scotland
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #18 on: November 25, 2007, 05:41:37 PM »
ha ha, after I typed all that out you have already posted it ::)

:D

Offline Chip

*
  • *
  •  2,055 2,055
  • Gainesville Florida USA
    • View Profile
Re: Mach 3 on lap top wont operate
« Reply #19 on: November 25, 2007, 05:52:44 PM »
Hi, Al

Also look in Config, P & Pin's, Motor Outputs, Change the Dir, Step Active Lows to the other state if its X then to Check, some step cont won't work if you don't change it

Chip