Hello Guest it is August 17, 2019, 05:26:13 PM

Author Topic: Mach2 profiling  (Read 3583 times)

0 Members and 1 Guest are viewing this topic.

Mach2 profiling
« on: November 21, 2007, 04:08:34 AM »
Hi there.

I am using Mach2 software to run a file that has been output from Rhino CAM to machine a surface profile with a flat on the top and a downward curved lip with a 1mm slot mill. On the top of this surface are a number of regions that the machine has to cut around. The machine seems to start on the curved lip and work up gradually until the first region to cut round is reached. It then works its way around one side and then lifts the tool to do the other side. however, although the display shows the Z value to be the same as before it lifted, there is a definite step after touch down. This then remains for the rest of the operation irrespective of the number of additional features that it has to cut round and lift off for. On checking, it appears that the machine is doing the curved lip with an offset, which it then ignores when it reaches the first tool lift off in the program. Thereafter, it follows the correct path.

I know there is no backlash problem with the machine and the simulation on both Rhino 3D and the G code simulator generate the correct profile. Is there an offset somewhere in Mach 2 that is causing this problem? The file has been generated with the following Gcodes: G21, G0, G17, G40, G80, G90, G61, and G43 and G01.

Any help would be gratefully received as this is driving me mad at the moment.

Thanks in anticipation Mark Humphrys

« Last Edit: November 21, 2007, 04:10:33 AM by best33 »

Offline Chaoticone

*
  • *
  •  5,570 5,570
  • Precision Chaos
    • View Profile
Re: Mach2 profiling
« Reply #1 on: November 21, 2007, 07:13:08 AM »
Can you post a picture of the cuts highliteing the problem area?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Mach2 profiling
« Reply #2 on: November 21, 2007, 07:34:22 AM »
I have attached an image and also a small block of the G code generated. The picture shows the step very clearly. The curve should be a smooth transition from the flat region by the openings. also of note is that at the bottom of the curve has produced another flat area, which is what leads me to suspect there is some offset setting going on somewhere.

Regards

Mark Humphrys
« Last Edit: November 21, 2007, 07:40:54 AM by best33 »