Hello Guest it is May 24, 2024, 02:15:24 AM

Author Topic: Z-axis jumping in feed speed (turning)  (Read 1437 times)

0 Members and 1 Guest are viewing this topic.

Z-axis jumping in feed speed (turning)
« on: August 17, 2021, 10:06:48 AM »
When i run a g-code program with G96 (Constant surface speed), my Z-axis jumps in feed speed randomly.
It wants to go full speed for a very short time. so the axis jumps a few cm during the program.

There is no error and when i run the same program again, the moment is different each time.
the code is just normal.

I found out when i run normal (without CSS) or jogging or a MDI G1 code there is no problem.
My RPM readout is stable.
I have the latest version of mach4 hobby (licensed) and pokeys57cnc

what can be the problem?
« Last Edit: August 17, 2021, 10:10:23 AM by budgen30 »
Re: Z-axis jumping in feed speed (turning)
« Reply #1 on: August 17, 2021, 10:41:59 AM »
I narrowed the problem to:  feed per revolution.

if i do feed per revolution (FPR) in my g-code i have this jumping feed problem.
if i do CCS + normal feedrate mode the jumping is not there.
if i do CCS + FPR there is jumping
if i only do FPR (without CSS) there is also jumping

maybe the RPM readout is not steady enough for FPR?
i use 1 signal per revolution. i have tried my rpm high speed filter at 100 and 500. makes no difference.
Re: Z-axis jumping in feed speed (turning)
« Reply #2 on: August 17, 2021, 02:04:44 PM »

I have a quick update. I read a post about electrical noise.
I notices a mini fraction of a second that the rpm was out of control (and the reaction of the machine jumping)

first i upgraded my aluminium sensor wheel with a magnet for a stronger detection signal. (aluminium gives a weaker signal).
The was better but the problem was not completely gone.

I checked my cable of my rpm sensor. i had bound the cable of the sensor to all the other wires of my machine. I isolated it from them: separate routing of the cable and i gave the cable a metal cover (metal speaker cable sleeve) from start tot the pokey board connectors. I also put a thick metal plate between my servodriver and the pokeys57cnc.

After these mods the problem was gone!
I hope it will stay that way.

I tried the same programs and threading, which went ok.