Hello Guest it is May 18, 2021, 02:10:43 PM

Author Topic: Problem with spindle index pulse config  (Read 108 times)

0 Members and 1 Guest are viewing this topic.

Problem with spindle index pulse config
« on: March 19, 2021, 02:12:52 PM »
Hey all, I have a problem with the lathe spindle speed. I set the rpm to 200 and the readout settles at 200 but the spindle is turning at about 380rpm. I've checked everything and can't find anything wrong.
Finally I tried another configuration file and it works ok, set at 200 and readout is 200rpm and spindle is now at 200rpm.
I have one pulse per rev on spindle.
So there is something in the config file wrong but I cannot figure out what it is.
Can someone help on what setting it could be that's doing it. Been trying for days now. This config is all set for my machine and I'd hate to start over again.
Thanks
« Last Edit: March 19, 2021, 02:14:24 PM by daseitz »

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: Problem with spindle index pulse config
« Reply #1 on: March 19, 2021, 08:26:02 PM »
What is in the pulley ratio screen for min and max and ratio.
Without engineers the world stops
Re: Problem with spindle index pulse config
« Reply #2 on: March 19, 2021, 08:51:49 PM »
The problem isn't in the ratio, it's the index pulse not being read correctly for rpm. The actual rpm is calculated from the index pulse. Even though it's pulsing at about 6.3 hz (378rpm) it shows it at 200rpm which would be 3.3 hz.

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: Problem with spindle index pulse config
« Reply #3 on: March 19, 2021, 09:04:25 PM »
But what is in the Min/Max.

Or turn the spindle index de-bounce to zero and see if that helps, if not keep adjusting it up 25 at a time and see if the reading improves.
« Last Edit: March 19, 2021, 09:06:26 PM by Graham Waterworth »
Without engineers the world stops
Re: Problem with spindle index pulse config
« Reply #4 on: March 19, 2021, 09:11:20 PM »
Graham you may be right.
I'll have to admit it that it makes no sense but the pully ratio does affect the read rpm. If I put in the correct ratio for the machine (motor to spindle) the rpm reads wrong. If I put in 1 then it reads correctly.  That would be correct if the index was on the motor not the spindle but that looks like it is the way it is working.
Is the index pulse usually on the motor or the spindle.
Mine is on the spindle like I would think it should be.

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: Problem with spindle index pulse config
« Reply #5 on: March 19, 2021, 09:14:49 PM »
But the ratio of spindle to index pulse is 1:1
Without engineers the world stops