Hello Guest it is May 24, 2019, 05:42:24 AM

Author Topic: Soft limits not working  (Read 2818 times)

0 Members and 1 Guest are viewing this topic.

Soft limits not working
« on: October 09, 2007, 05:58:57 PM »
Hi I just can't seem to get the soft limits to work.

If i do a G0 past them and it will go past.

I am running in air i have managed to get every thing else working.

I am using vers 3.48 and i know the manual is some way behind.

Anyone got any ideas.

Thanks

The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

Offline Chaoticone

*
  • *
  •  5,496 5,496
  • Precision Chaos
    • View Profile
Re: Soft limits not working
« Reply #1 on: October 09, 2007, 06:26:17 PM »
Look in the tutorials section. I tried to cover most of the soft limits settings in the G100 Set-up guide. The softlimit settings will be the same for your set up I think. What kind of hardware are you running?

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: Soft limits not working
« Reply #2 on: October 09, 2007, 06:44:40 PM »
Hi Brett and thanks.

I am getting the software working in the warm before i go to my cold workshop. ;D

I am using the C11 bob from cnc4pc.

So rigging all hard limits, charge pump, estop, relays, every thing is OK

I set the soft limit OK on the setup page as well but they are just bypassed by a G0 command

Is there a bypass somewhere

Phil_H

I just had a look at the G100 setup i see the problem i set the soft max to what would be the maximum travel allowed on my machine.

So i am going to have a play with the correct settings

Maybe you could change the title of the tutorial to include soft limit settings

Phil_H
« Last Edit: October 09, 2007, 06:54:32 PM by Phil_H »
The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable

vmax549

*
Re: Soft limits not working
« Reply #3 on: October 13, 2007, 04:27:43 PM »
Phil soft limits will only work AFTER you have referenced your machine. Mach has to know exactly where it is really at in order to use the softlimits.
Re: Soft limits not working
« Reply #4 on: October 13, 2007, 09:04:40 PM »
Hi Brett and thanks.

Is there a bypass somewhere

Phil_H

Phil_H

There's the clue, i didn't enable  softlimits on the first screen Doh!

So its all OK now

Phil_H

The Good Thing About Mach3, Is It's very Configurable

The Bad Thing About Mach3, Is It's Too Configurable