Hello Guest it is May 09, 2021, 01:05:04 PM

Author Topic: Feed rate does not stay stable!!  (Read 375 times)

0 Members and 1 Guest are viewing this topic.

Feed rate does not stay stable!!
« on: November 20, 2020, 08:16:18 AM »
Hi

ı use windows 7 32 bit and mach3 R3.043.066 version.My control card is paralel port 4 axis.My feed rate is 13000. The feedrate is constantly changing between 12500-13200 when I move it manually from the keyboard.
This situation causes shaking in the machine.The same happens when g code is running.I would appreciate it if you could help me solve this issue.

Thanks

 

Offline DAlgie

*
  •  314 314
    • View Profile
    • Algie Composite Aircraft
Re: Feed rate does not stay stable!!
« Reply #1 on: November 20, 2020, 01:22:19 PM »
Not knowing much, or anything in fact, about your machine, seems that your feedrate is in MM, I would say that is a very high rapid feedrate and its possible that your motors are stalling. Does the position of zero change after that or does the machine come back to the same physical zero point?

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: Feed rate does not stay stable!!
« Reply #2 on: November 20, 2020, 03:17:12 PM »
The topic was locked because you clicked 'Report to moderator'

It should be fine now repost what is missing.

Without engineers the world stops
Re: Feed rate does not stay stable!!
« Reply #3 on: November 21, 2020, 02:00:49 AM »

My machine is step per:32 velocity 13000 mm/s accelaration 300 I use 2 modules rack and pinion on the axes. no error when i reset it.  It returns to point 0. the problem remains unstable Feed rate. The same problem persists when i unplug the parallel port.  The feed rate value does not remain constant when I manually advance it with the parallel port disconnected.

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate does not stay stable!!
« Reply #4 on: November 21, 2020, 03:25:10 AM »
If the Mach3 (on screen) feed-rate varies when the Parallel Port is disconnected that would indicate that your PC is not up to the task of providing the necessary pulse stream fast enough.
The Parallel Port is really not that brilliant when operating at high kernel speeds so it may be best if you consider using an External Motion Controller. There are many to choose from but avoid the cheap Chinese types. The ESS from Warp9 is good and that will operate with Mach3 and also Mach4 (if you need to move on from Mach3 at some time in the future).

Tweakie.
KEEP SAFE !
Re: Feed rate does not stay stable!!
« Reply #5 on: November 21, 2020, 12:19:08 PM »
If the Mach3 (on screen) feed-rate varies when the Parallel Port is disconnected that would indicate that your PC is not up to the task of providing the necessary pulse stream fast enough.
The Parallel Port is really not that brilliant when operating at high kernel speeds so it may be best if you consider using an External Motion Controller. There are many to choose from but avoid the cheap Chinese types. The ESS from Warp9 is good and that will operate with Mach3 and also Mach4 (if you need to move on from Mach3 at some time in the future).

Tweakie.

Thanks for your answer. is there no solution other than adding a hardware?  I live in turkey and very difficult to find here and I have no time ...
Re: Feed rate does not stay stable!!
« Reply #6 on: November 21, 2020, 12:21:11 PM »
I must say without forgetting.  I installed mach4 demo hoby and tried it there was no fluctuation.  feed rate was fixed

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate does not stay stable!!
« Reply #7 on: November 22, 2020, 01:00:22 AM »
I must say without forgetting.  I installed mach4 demo hoby and tried it there was no fluctuation.  feed rate was fixed

Not really a fair comparison - if you had also installed the Mach4 Parallel Port driver plugin / motion controller the results may well have been the same as they were with Mach3.

Tweakie.
KEEP SAFE !
Re: Feed rate does not stay stable!!
« Reply #8 on: November 22, 2020, 03:12:54 AM »
I must say without forgetting.  I installed mach4 demo hoby and tried it there was no fluctuation.  feed rate was fixed

Not really a fair comparison - if you had also installed the Mach4 Parallel Port driver plugin / motion controller the results may well have been the same as they were with Mach3.

Tweakie.

Do you have any solution other than adding hardware?

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Feed rate does not stay stable!!
« Reply #9 on: November 22, 2020, 03:53:42 AM »
You could possibly try to reduce the axis Velocity in Motor Tuning and then reduce the Kernel speed - bit at a time, trial and error.

Try a much improved (lean and faster) PC.

Perhaps download and install the current version of Mach3;  https://www.machsupport.com/wp-content/uploads/2013/04/Mach3Version3.043.exe
(There were a number of issues with version .066 and it was withdrawn)
Make a backup of you existing Mach3 folder before installing the current version over the top of your existing version.

I don't think the Mach3 Parallel Port driver was ever intended to support a 13000 units / min feed-rate so the only real solution is an external motion controller (13000mm/min is something I have never tried).

Tweakie.
KEEP SAFE !