Hello Guest it is May 09, 2021, 08:46:13 AM

Author Topic: X axis looses steps in the exact same line of code each time.  (Read 181 times)

0 Members and 1 Guest are viewing this topic.

X axis looses steps in the exact same line of code each time.
« on: November 21, 2020, 08:16:59 PM »
Hi there,
Im loosing steps on my X axis at a certain line in the code. I'm running mach3 on windows 7 with a printer port to a breakout board then to individual cards. My stepper motor will make a buzzing noise just like if you were to try to run you axis into an end stop. it lasts for a second or two. It doesn't do it every time but almost every time. I made 7 pieces and it did it on 5 of them.
I have 1200 OZ motors, ball screws and linear rails. I removed the cars off of the rails and checked to make sure they were not clogged with sawdust the cars and the gantry head moves easily along the rails. the ball screw also rotates freely.
I'm cutting slots with a 3/4" bit in Ash I plunge down 3mm at 190mm per minute, then it travels to the end of the slots and plunges again.. travel speed is 1800mm per minute. My acceleration is set to 120mm per second in ports and pins. It happens right after a plunge as it starts to travel it makes it about a 1/4 inch then hangs up. there are 9 slots and it only does it in one slot at the same depth and place. I dialed down my acceleration and speed. same thing.
I run all shielded cable...…. power supply in in a separate box from the BOB and control cards...…
Here is the lines of code where it happens.
This is in mm

Z-12. F190.
X417.014 F2000.
Z-15. F190.
X436.014 F2000.
Z-18. F190.
X417.014 F2000.
Z-21. F190.
X436.014 F2000.
Z-24. F190.

Any suggestions would be great!

Glen
« Last Edit: November 21, 2020, 08:18:51 PM by GHiggs »

Offline Graham Waterworth

*
  • *
  •  2,322 2,322
  • Yorkshire Dales, England
    • View Profile
Re: X axis looses steps in the exact same line of code each time.
« Reply #1 on: November 22, 2020, 10:34:16 PM »
Double your accelaration time or halve the velocity and try that. if its ok keep adjusting the value by 10% intil you get problems then back it of 10%

Without engineers the world stops