Hello Guest it is July 24, 2024, 09:39:18 PM

Author Topic: 3040 CNC with Mach3  (Read 1127 times)

0 Members and 1 Guest are viewing this topic.

3040 CNC with Mach3
« on: June 29, 2020, 02:03:38 PM »
Hi all. New user with experience of 3018.

Having a problem with my 3040, USB connection, working in mm. I have done a few cuts and they have been fine then all of a sudden, halfway through a job it started to lose height and cut progressively deeper as the job went on. When you jog the cutting bit back to home, just touching the wood surface again where it started (Zeroed at that height), Mach3 thinks it's above the workpiece, so far, anything up to 6mm depending on the job.

Things I have checked/done...

Not hit any hard limits.
All moving parts have been marked and don't seem to be moving (e.g. bit hasn't slipped, grub screws tight on the coupler, motor not moved.
Tried swapping the x and z steppers over but no change
Wood and bed are level with cutting height
It gets progressively worse the longer the job runs
Tried slowing the acceleration/velocity but may need to investigate this further with advice.

Any ideas/advice would be greatly appreciated
Re: 3040 CNC with Mach3
« Reply #1 on: June 29, 2020, 04:47:52 PM »
Have also now found all 3 axis are out. After a 20 minute cut I returned it to it's physical starting point which should have meant 0 reading on all axis but they all read +1.5 to +1.7mm.

Offline Tweakie.CNC

  • *
  •  9,214 9,214
  • Super Kitty
Re: 3040 CNC with Mach3
« Reply #2 on: June 30, 2020, 01:04:30 AM »
Generally, problems such as this (assuming you have thoroughly checked all couplings for tightness and slides are not binding, etc) are caused by loss (or gain) of steps.

If you attach your <your profile>.xml file (Mach3 folder) we can check your Mach3 settings and perhaps suggest a solution. Rename your .xml file to a unique name such as lutmfurl.xml before posting.