Hello Guest it is October 24, 2020, 05:45:54 AM

Author Topic: z after running file  (Read 7941 times)

0 Members and 1 Guest are viewing this topic.

z after running file
« on: September 27, 2007, 09:12:09 PM »
is it normal to have to rezero z  when repeating a file over and over?
also, when zero with my plate the machine tells me it is moving to a safe z height of 1 inch.  really its about 4 inches.  can this be changed?
will a feed rate that is too high cause jerk and chatter in ovals and circles?
thanks
kent

Offline Hodges

*
  •  18 18
  • Freeing trees from silence
    • View Profile
    • Hodges Handcrafted Guitars
Re: z after running file
« Reply #1 on: September 27, 2007, 11:18:45 PM »
Kent, I am new to this, but believe it or not I can answer some of this.
You have to add a line to your gcode to tell the machine to return to zero. You can do this by clicking on the "edit" button located right above the loaded gcode code on the main screen. Just type in what ever coordinates you want the machine to return to and it will do it every time you run this gcode. On reading your question again, it is only the Z that youa re wanting to re-zero.... That tells me that it is quite possible that your bit is slipping down in the collet. This could be due to heat, not tight enough in the first place, or that you are trying to push into the work too far, which can cause the stepper moter to "slip" and not be on a true reading after slipping. It would be my advice to tighten your bit in your tool (make sure the collet AND the bit are clean and dont have any residues on them). Also check to see how deep you are trying to plunge the bit into the work. You may be going too deep (which is why you are hearing the chatter and jerks).

I found how to edit the safe z, but I coudlnt tell you where I found this...sorry. Maybe someone else will chime in and tell you an easy way to find it.

a feed rate that is too high for the tool you have loaded will cause the machine to jerk and chatter. Either you are too deep, or have the wrong tool, or you are going too fast.. decide which it is and change it.

Hope this helps!
Ken
« Last Edit: September 27, 2007, 11:23:05 PM by Hodges »
Hodges Handcrafted Guitars
http://www.hodgesguitars.com
Re: z after running file
« Reply #2 on: September 28, 2007, 04:33:50 PM »
z isn't slipping down.  when i tell it cut again it's too high.  usually about an inch.  this also happens if i do a goto zeros after cutting.  x and y go to zero.  i'll try your other suggestion on slowing down my feed rate. kinda thought that was the problem. maybe someone will point me in the right direction on changing safe z. thanks much.
kent
Re: z after running file
« Reply #3 on: September 30, 2007, 12:08:40 AM »
This problem started for me when I upgraded to version 2.42 and is still in 2.48. The best I can figure out is that Mach is inserting an offset, but I can't figure out were it is getting the numbers.

Offline jimpinder

*
  •  1,232 1,232
  • Wakefield, West Yorks, UK
    • View Profile
Re: z after running file
« Reply #4 on: September 30, 2007, 04:16:39 AM »
I do not understand your problem.

Either your tool IS slipping - or you are not starting at the right place - it is as easy as that.

You do not say how you set up the machine before running. You cannot throw the work on the table, and set the machine off - you must somehow zero the machine to tell it where everything is. Neither do you say where your GCode program expects  X0 Y0 and particularly Z0 to be

Although most of my work is with the lathe, the same things apply using the mill. In my case my GCode starts with Xand Y position 0 on the bottom left hand corner of the work AND Z 0 is when the tool is just touching the work surface - I then zero the DRO for Z. My first move in the code is then to lift Z and move it to the start of the cut.

If you ARE doing that then you either have a serious problem with your Z axis missing steps, or your code does not actually finish where you think it does.

1. Run the program on Mach 3 without the machine connected - and see where the DRO's are when it is finished.
2. The only problem with my milling attachment was that it had a strong spring on to hold the weight of it. Using it manually you never noticed, but putting a stepper on it was difficult - in that the stepper had difficulty in driving the head DOWN against the spring. I had to unravel the spring to make the head more balanced.
3. I take it that you have adjusted and corrected backlash and all the other bits and pieces.
4. Go through your tool table, especially for the tool number you are using, and delete anything to do with tool length. Make sure in geneal config, etc anything to do with offsets is off.

It follows that your Z height should always follow the DRO (as should the other Axis) - insert some pauses in the Gcode and check the various positions at different places in the program.

Finally put your Gcode on the forum and see if anybody else has the same problem with it.

Not me driving the engine - I'm better looking.
Re: z after running file
« Reply #5 on: September 30, 2007, 06:10:54 AM »
i zero the machine with a z plate for the z axis.  cut  the file.  now if i either tell it to recut the file or goto zeros the z is about 1 inch high.  x and y  are always on the money.  at the present it seems to happen all time not just 1 file.  thanks to all.
kent

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: z after running file
« Reply #6 on: September 30, 2007, 06:21:56 AM »
How does your plate work ie is there a  macro for it. could be you are putting the offset in from the macro and its being cancelled after the first run. Try running without using the plate, just touch off your work and press the Z axis Zero button and see if it works fine. If it does then looks like its the routine of using the plate thats causing the problem.

Hood
Re: z after running file
« Reply #7 on: September 30, 2007, 01:34:14 PM »
When I start a part I mount my fixture or plate. I than than set my zeros for x,y,z. I am not running any macros. At the end of the part I press the go to Z button. In 2.42 the Z location for a axis might change and the numbers were random. Now in 2.48 only the Z axis is changing. The distance is not always the same.
This issue is on old files that I have run for years and new ones that I just created yesterday.
I am going to trash the Mach 3 file today and start from scratch with setting up my mill. I always uninstall my old version of Mach before I install the new one. That does not remove all of the preference files and maybe one of them went bad.

Mark

vmax549

*
Re: z after running file
« Reply #8 on: September 30, 2007, 05:40:16 PM »
Guys try updating to V2.50 or higher.(;-) TP
Re: z after running file
« Reply #9 on: September 30, 2007, 05:42:32 PM »
Were do I get 2.50? The 2.48 is the highest I see on the download page.



Mark