Hello Guest it is January 20, 2022, 08:36:32 PM

Author Topic: Mach3 Camera Plugin video window  (Read 1268 times)

0 Members and 1 Guest are viewing this topic.

Mach3 Camera Plugin video window
« on: February 23, 2020, 03:12:13 PM »
So I have been using Klaus's camera plugin v 2.14b for years now.  I decided to upgrade to ver 3.09.  Things are working good except for one issue.

 How long does it take to bring up the video window?  At the longest, it can take up to 8 seconds.  Sometimes it will take only one second.

 I'm using a Logitech webcam.  I have updated to the latest drivers.   Using Logitech's webcam software, the video window only takes about 1-2 seconds to pop-up.

Klaus has written a great tool for Mach users.  I have really come to depend on it in all my cnc work.  Thank you Klaus.

Thanks everyone for any insight into this.
Rick


 
Re: Mach3 Camera Plugin video window
« Reply #1 on: February 24, 2020, 06:50:53 AM »
I'm using v3.09 of Klaus's plugin and have been for quite some time. Mine takes about 2-3 seconds to open.
I'm only a hobby user, so I'm ok with the time it takes to open. :D
Klaus made quite a few functionality changes between v2.14 and the current version. My guess would be that's why it takes longer.
I've never had it take anywhere near 8 secs.
Re: Mach3 Camera Plugin video window
« Reply #2 on: February 25, 2020, 05:03:36 PM »
Hi,
someone had the same issue, he had other camera plugins running at the same time. Please move unused camera plugins out of the plugin directory.


Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: Mach3 Camera Plugin video window
« Reply #3 on: February 25, 2020, 05:52:17 PM »
Hello Klaus.
I had already removed all the unused plugins from the directory folder because I just didn't like the clutter, so maybe that's why I haven't had any start up issues like the OP has.
Interesting.
Re: Mach3 Camera Plugin video window
« Reply #4 on: February 26, 2020, 11:47:03 AM »
Thanks for all the replies.

I still have Camera plugin v 2.14d in the directory, but under Config Plugins, I have it disabled.

Also I have Video - B.Barker Ver 1.0.  I have tried to disable this under Config Plugins, but everytime I start Mach3, it is enabled.

Klaus, I will move both these plugins out of the directory.


I have been playing with the loading Camera plugin v 3.09 this morning, and out of 10 times it is always loading in 1 to 3 seconds.  And a few times after this it will take maybe 5 seconds, but then it will load in 1 to 3 seconds.


Thanks.
Rick
Re: Mach3 Camera Plugin video window
« Reply #5 on: March 15, 2020, 05:57:34 PM »
And so the saga continues...I was using the CNC machine this morning and the camera plugin was taking an easy 8 to 9 seconds to load.  And I reloaded it about 10 times, just to get an average.  So I did a search for "camera plugin" on this forum and I came across someone else, not with this issue, with a problem using Klaus' ver 3 plugin.  It came out in the thread that he was using an AMD machine and when he switched to an Intel machine, all was good.

 I am using an AMD Sampron 140 processor.  I switched back to ver 2.14d and the plugin loads consistently in under than 2 seconds.  I did have to slow the refresh rate down to 80. Any faster and the jog would not work smoothly. 

As an aside, I noticed in ver 3 that the fastest refresh rate was 100.

Any comments would be welcomed.
Thanks.
Rick