Hello Guest it is January 23, 2022, 11:12:35 PM

Author Topic: I can Jog Fine but everything stutters when running GCode or even calibrating.  (Read 2110 times)

0 Members and 1 Guest are viewing this topic.

I just built my CNC.  I used
Nema 23 Stepper Motors 270 Oz.
TB 6560 MD 430 motor controllers
and a parallel 5 axis CNC breakout board not sure if there is even a model number.
Amazon description:
4 Axis Nema23 Stepper Motor 270oz-in 76mm 3A Dual Shaft+TB6560 MD430 Driver CNC Controller Kit for CNC Router Engraving Milling Machine

I can move all axis's around in Mach3 using the arrow and Pageup/down keys and they move fine.  When I go to run a test Gcode or calibrate the motors under "Settings" "Set Steps per Unit" the motors will just make noise and not really move the axis but stutter a bit.  I purchased a new USB breakout board but could not get the motors to move with that board at all. As a test, I wired only one axis motor with new wiring and did not put it near any other wiring and had the same result.  I was trying to rule out interference.  I am using Windows 7, 8 gig ram.  I have not tried a different computer as I only have one with a parallel port.
Looking for any suggestions you may have. 
Thank you
Thank you in advance.
Hi,
that sounds like Machs parallel port not getting CPU service.

Machs parallel port is not the same as Mach3, the Windows application. The Windows application sends numeric trajectory
data to the motion controller, in the case Machs parallel port. This chunk of code lives in the kernel and almost has to shove
the Windows kernel aside to run properly. It takes that numeric data and generates the required pulse streams and transmits them
to the outside world on the parallel printer port.

Any software or services that run on the PC compete with Machs parallel port. The advice is shut everything BUT Mach down
when running. Note also that some computers just don't ever run Machs parallel port well while another PC of the same spec
does a great job.....and no rhyme nor reason.

If you get discouraged trying to get Machs parallel port to work get an external motion controller like an Ethernet SmoothStepper
or a UC300. DO NOT BE TEMPTED BY CHEAP CHINESE CONTROLLERS, they just don't work like they should.

An external motion controller takes over the roll of generating pulse streams from numeric trajectory data. Therefore the PC
is relieved of that duty and therefore just about any PC (desktop/laptop/Windows7,8,10/ 32 bit or 64 bit) will run Mach just fine.

Craig
My wife left with my best friend...
     and I miss him!
Thank you for your quick and thorough response. As I understand you, I should try a different computer, or perhaps put a fresh load of Windows on this one to make sure it is dedicating as much processing power as possible to Mach3.  When that doesn't work I should buy a good quality external motion controller and put it between the machine and breakout board to relieve the computer from doing so much work.  Lastly, next time I build something I should spend some money to get good quality equipment to start with.
Again, thank you for your help.  It will be a week or two but I will report back with my findings.
Have a good day.
Thank you in advance.
Hi,

Quote
As I understand you, I should try a different computer

Yes, if you can beg, borrow or steal another desktop PC with Windows 7 32 bit or earlier, or even buy one if its real cheap.

My original PC started giving me grief so I bought a MiniITX single board PC with a low power dual core Atom with 4G RAM.
It has one built in parallel port and I added another with a PCI card. That gave me two parallel ports and I ran Mach3 like that
for two years...and it went well PROVIDED you didn't do anything silly and especially run other software or services on it.
I loaded Windows 7 Embedded (Standard) 32 bit. Embedded is very much like Windows 7 retail but you can chose not to load certain code,
for instance I did not load a browser, any anti-virus/malware code, nor a firewall, nor any multimedia crap that I don't need.

More recently I bought an Ethernet SmoothStepper (ESS) and upgraded to Mach4 but using the same gutless-little-wonder PC
and it runs fine. In fact it runs SO MUCH BETTER than the parallel ports ever did, without stuttering, stalling and all the other
bulls*********t that you have put up with and a parallel port. I would have to commend the ESS, and have been informed that other
external controller like the UC300 and 57CNC work equally well. All of these devices are in the range $150-$200, so would be
cheaper than a new PC.

Craig
My wife left with my best friend...
     and I miss him!
Thank you Craig
I got a different computer and put a fresh load of Windows 7 32 bit on it.  For everyone else, 64 bit did not work.  My motors run a lot smoother.  I can calibrate, and even drew a circle.  However, if I set "home" for the axis I am calibrating, calibrate it at 10", put in 10" as the distance it has moved, then hit "go home" it rarely ends up in the same spot.  It will be off about 1/16 - 1/8 of an inch.  I continue to do the same and always enter 10" and it continues to get off more each time.    I am playing with the backlash settings but have not been able to resolve the issue yet.  It does this for all three axis.  I will continue to work with it and let you know what happens.  Thanks again for your help.
Thank you in advance.

Offline ZASto

*
  •  401 401
    • View Profile
64-bit OS is no good with parallel port.
Driver for PP that Art wrote works only on 32-bit systems.

As Craig wrote zillion times external controllers are only way to go on 64-bit systems. And, of course, not some Chinese knock-offs.
Even Russian PLCM-E3 works correctly (if you can find plugin for Mach3 :) )
Make no mistake between my personality and my attitude.
My personality is who I am.
My attitude depends on who you are.
Hi,

Quote
It will be off about 1/16 - 1/8 of an inch.  I continue to do the same and always enter 10" and it continues to get off more each time.

Sounds like your steppers are missing steps. Try tuning them to half their current speed and acceleration and try again.

Quote
I am playing with the backlash settings but have not been able to resolve the issue yet.

Disable and/or set the backlash settings to zero and leave them there. They are just confusing you. You need to be able to
MDI 10 inches the the left and then 10 inches to the right and come back to the same location within the bcaklash of the machine,
which should be minimal.

If the backlash of your machine is 1/16 to 1/8 inch then fix your machine. Expecting software to overcome that sort of lash is a fools dream.

Craig
My wife left with my best friend...
     and I miss him!
Good day,

I have slowed everything down to a crawl and have the same issue.  Do you think purchasing a Ethernet SmoothStepper would solve the issue?  Perhaps this is still a computer issue?
Thanks
Thank you in advance.
I have also worked with the settings for Amps. torque and steps.  Thanks
Thank you in advance.
Hi,

Quote
Perhaps this is still a computer issue?

I believe you are correct. That you have tried two different PC's with the same result rather shakes my
confidence in that conclusion however.

What most people don't realise is that Mach3 is really in two parts.

The first part is a Windows application. It is a GUI, Gcode interpreter and trajectory planner. It will run on just about any PC,
32 bit, 64 bit, laptop, XP through to Windows 10. Its not a difficult program to run at all.

The second part is Mach's parallel port engine. It takes numeric trajectory data (from the first part) an converts that into
pulse streams. It uses interrupt driven timers to do so. Windows however makes VERY extensive use of the interrupt system for
its own purposes. As a result Mach's parallel port struggles to get CPU service and has to almost 'shoulder Windows out of the way'.

That Mach's parallel port runs at all came as a huge surprise to many programmers, and to my knowledge no-one other than
Art Fennerty was ever able to get it to work.

Some of the consequences of that history is that Mach's parallel port engine is VERY VERY sensitive to the hardware of the PC
on which it is to run and also very sensitive to other software and/or services installed on it. Certain operations cause Mach's parallel port
to stutter and stall, screen refreshes particularly. For this reason you are recommended to run a good video card so that screen refreshes
don't interfere with the smooth running of Mach's parallel port.

That you have tried two PC's and neither run the parallel port properly could just be bad luck. There used to be a list of things that you could
do to your PC to help, although I have not seen that list for some years.

The other alternative is an external motion controller like an ESS. I have one and have used it with Mach4 for five years, its great.
While I never had a great deal of trouble with Mach3 and Mach's parallel port I found that when I switched to the ESS that the smoother
and stutter free motion allowed me to run my stepper 33% faster without losing steps and my machine never stutters. To be honest I
think anyone trying to run Mach3 on a parallel port is being foolish. An ESS is not much more than a good stepper and driver....can anyone
seriously use the excuse 'an ESS costs too much'?

Quote
I have also worked with the settings for Amps. torque and steps.  Thanks

Don't bother with all that. Set the current to the rated current of your steppers, and set the microstepping to 8 microsteps per full step,
ie 1600 steps/rev and leave them there. Fiddling with those settings will get you no closer to solving the issue of Mach stuttering.

Craig
My wife left with my best friend...
     and I miss him!