Hello Guest it is May 14, 2021, 10:09:51 PM

Author Topic: Mach4 Homing doesn't set DRO's to zero  (Read 462 times)

0 Members and 1 Guest are viewing this topic.

Mach4 Homing doesn't set DRO's to zero
« on: January 13, 2020, 12:03:43 PM »
Can someone tell me why, when I Ref All Home, and the machine homes to the switches, Mach4 doesn't zero the DRO's?
Re: Mach4 Homing doesn't set DRO's to zero
« Reply #1 on: January 13, 2020, 12:52:29 PM »
Hi,
most likely you have non-zero home offsets in your Homing table or you have non-zero residual G92 offsets.
To check the later look on the Machine Diagnostics tab.

Craig
My wife left with my best friend...
     and I miss him!
Re: Mach4 Homing doesn't set DRO's to zero
« Reply #2 on: January 16, 2020, 02:31:46 PM »
I have neither; however, it seems to reset to zero now. Having all sorts of issues with offsets. left an email with support.
Re: Mach4 Homing doesn't set DRO's to zero
« Reply #3 on: January 16, 2020, 03:48:01 PM »
I don't mean to hijack, but where is this Machine Diagnostics tab located? I dont see it in Mach4 Lathe.
Re: Mach4 Homing doesn't set DRO's to zero
« Reply #4 on: January 16, 2020, 05:28:24 PM »
Hi,
I don't think there is a Machine Diagnostics tab in Mach4 Lathe.

I have had 'difficulties', if that is a fair description, where when I zero the Z axis as I have to do several times throughout
a circuit board job and the G92 offset has mysteriously grown from zero to 0.16mm or -0.045mm or some other random number.
When making a circuit board I need to control cutting depth to 0.005mm or better and so having what appears to be a random
G92 offset confuses the issue. Its no problem to reset the G92 but I am still bemused as to why it happens. I am making circuit
boards 'flat stick' for work and so have not really taken the time to work out why this happens.

As is often the case with Mach4 its not a fault or bug but a process or feature that I do not fully understand. Once the process is explained
then its no longer a problem. I'm hoping this is an example of the same thing.

Craig
My wife left with my best friend...
     and I miss him!

Offline Stuart

*
  •  264 264
    • View Profile
Re: Mach4 Homing doesn't set DRO's to zero
« Reply #5 on: January 17, 2020, 07:54:57 AM »