Hello Guest it is July 08, 2020, 07:13:20 AM

Author Topic: "Reference All" Jitters in Motors (M3)  (Read 361 times)

0 Members and 1 Guest are viewing this topic.

"Reference All" Jitters in Motors (M3)
« on: January 09, 2020, 07:18:25 PM »
Hey all,
I have a EZ-router scorpion black 2011 4x8 cnc.
Have had it in storage for a while, just got it out and have been cleaning it up.

Whenever I reference all axis the Y-axis seems to have some major jitters, sometimes the x and z as well, but mostly the Y.
I attached a video showing the y axis with the gear not even attached to the table.

I am using the XML setup by ez-router when you purchase the machine.
After it reffs home and jitters its way there I can run Gcode and its perfect, no issues.

But when I "ref all" or even "go to home" it jitters it way there.
Any ideas? I will also attach my XML below

On mach3 R3.00

VID - https://www.youtube.com/watch?v=jQRA2B43E_8


Thanks all.
David

Offline TPS

*
  •  1,607 1,607
    • View Profile
Re: "Reference All" Jitters in Motors (M3)
« Reply #1 on: January 10, 2020, 06:03:53 AM »
had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: "Reference All" Jitters in Motors (M3)
« Reply #2 on: January 10, 2020, 09:49:37 AM »
How can I view that?


had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.
Re: "Reference All" Jitters in Motors (M3)
« Reply #3 on: January 10, 2020, 09:59:44 AM »
How can I view that?


had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.

... then click on the flashing Ref All Home button.
Re: "Reference All" Jitters in Motors (M3)
« Reply #4 on: January 11, 2020, 12:26:20 PM »
I would be curious to know if your "jitter" problem also happens when you send the X, Y, and Z axes independently to Machine Zero ("Home" position). I think I had the same problem.

Move your X, Y,  and Z axes to some random location on your table. Go to the 'MDI' tab in Mach 3 and enter ('Input' text box) the following to send each axis to the Home position:
G01 Z0 (hit the Enter key)

G01 X0 (hit the Enter key)

G01 Y0 (hit the Enter key)
Then repeat the above process, but use G00 this time.
(F.Y.I. - G01 is a Linear interpolation move and G00 is a Rapid positioning move)

Did the jittering still happen?

Thanks,
Roger
Re: "Reference All" Jitters in Motors (M3)
« Reply #5 on: January 11, 2020, 01:31:31 PM »
had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.

had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.
How can I view that?


had a quick look to your XML looked ok so far.
interesting would be the code of your Ref All button.

... then click on the flashing Ref All Home button.


Here is the script.


DoButton( 24 )
While IsMoving
Wend
code"(Z Axis is Referenced)"
code"G4 P.1"


DoButton( 22 )
While IsMoving
Wend
code"(X Axis is Referenced)"
code"G4 P.1"


RefCombination ( 10 )
While IsMoving
Wend
code"(Y Axis is Referenced)"
code"G4 P.1"

While IsMoving
Wend

If(GetOEMLED(23)=false) Then 'This will turn on the softlimits on
  DoOEMButton(119)
End If
While IsMoving
Wend

code"(All Axis are Referenced)"
While IsMoving
Wend

code"G4 P.1"
While IsMoving
Wend

Code"(Moving to Home Position)"
Code"G28"
While IsMoving
Wend

DoButton(7)
While IsMoving
Wend

Code"G4 P.1"
While IsMoving
Wend

Code"(X and Y axis are Homed and Zeroed)"
   
Re: "Reference All" Jitters in Motors (M3)
« Reply #6 on: January 11, 2020, 03:07:20 PM »
I would be curious to know if your "jitter" problem also happens when you send the X, Y, and Z axes independently to Machine Zero ("Home" position). I think I had the same problem.

Move your X, Y,  and Z axes to some random location on your table. Go to the 'MDI' tab in Mach 3 and enter ('Input' text box) the following to send each axis to the Home position:
G01 Z0 (hit the Enter key)

G01 X0 (hit the Enter key)

G01 Y0 (hit the Enter key)
Then repeat the above process, but use G00 this time.
(F.Y.I. - G01 is a Linear interpolation move and G00 is a Rapid positioning move)

Did the jittering still happen?

Thanks,
Roger


I tried all 6 commands and they all worked perfect.
Tried again by just moving everything far from home and clicking "go to home" and all axis violently jittered home.... Makes no sense, hopefully the script above will be helpful in solving my problems?

Thanks guys
David

Offline TPS

*
  •  1,607 1,607
    • View Profile
Re: "Reference All" Jitters in Motors (M3)
« Reply #7 on: January 12, 2020, 05:10:43 AM »
open vbscript Editor, Mainmenue    Operator -> VB Script Editor

then copy/paste this code into the Editor

Code: [Select]
DoButton( 24 )
While IsMoving
Wend
code"(Z Axis is Referenced)"
code"G4 P.1"


DoButton( 22 )
While IsMoving
Wend
code"(X Axis is Referenced)"
code"G4 P.1"


RefCombination ( 10 )
While IsMoving
Wend
code"(Y Axis is Referenced)"
code"G4 P.1"

While IsMoving
Wend

If(GetOEMLED(23)=false) Then 'This will turn on the softlimits on
  DoOEMButton(119)
End If
While IsMoving
Wend

code"(All Axis are Referenced)"
While IsMoving
Wend

code"G4 P.1"
While IsMoving
Wend

Code"(Moving to Home Position)"
Code"G28"
While IsMoving
Wend

DoButton(7)
While IsMoving
Wend

Code"G4 P.1"
While IsMoving
Wend

Code"(X and Y axis are Homed and Zeroed)"

use the >|| button (Step Into Script) to run code line by line and see where the jitter happens.

BTW, do you have any values in

Config -> Homing/Limits -> Home Off. ?


anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: "Reference All" Jitters in Motors (M3)
« Reply #8 on: January 12, 2020, 10:01:32 AM »
David,
I don't know your level of expertise with CNC routers, but the 'Go to Zero' button on the Mach 3 main screen is NOT used for sending your X, Y,  and Z axes to the "Home" position. That button sends your axes to any one of the six Work Offsets (G54 -G59) you set up and select on the Offset screen. Mach 3 defaults to the G54 offset. So what ever value you have in the G54 Work Offset screen is where Mach 3 will send the router when you hit the Go to Zero button. Remember, the G54 offset value is ALWAYS referenced (measured) from the Machine Zero (Home position).
The Go to Zero button will also send your router to any location you set up for "Part Zero"  (X=0, Y=0, Z=0) on your work piece (wood). Part Zero is usually located at the lower left-hand corner of your work piece. Once you move your three axes to that corner and "zero out" the X, Y, and Z DROs (Digital Read Out) in Mach 3, the Go to Home button will go to that position automatically every time you hit that button - as long as you start at the HOME position.
Ok, so don't use the Go to Zero button for Homing.
(Sorry for being so long winded)
Now, it's the G28 X0 Y0 Z0 G-code command that will send any CNC router to the Home position. Most G-code programs will have the G28 command at some point in the program to raise the Z-Axis first, then the X and Y axes.
You can see this in action by going to the MDI screen and typing the following:
(Make sure all fixtures and clamps are out of the way.)

G28 X0 Y0 Z0  (Rapid movement)
or
G28 Z0 (hit Enter)
G28 X0 (hit Enter)
G28 Y0 (hit Enter)
If you get a hand held "Pendant", you can set it up (OEM codes) so when you hit the Home button on the pendant it will automatically send your router to the Home position. The OEM codes also work in "Script" files.

Let's get back to your problem. Here are a few suggestions:
1. Go to the Config tab on the menu bar and select 'Homing/Limits' from the list. You should have all green check marks under the heading 'Auto Zero' column. Also, play with the Speed percent setting. It may be too slow/fast.
2. Go to the Config tab on the menu bar and select 'Safe Z setup'. You should have  a check mark next to 'Allow Safe Z moves'.
3.If you have the 'Soft Limits'  button turned on (green) on the main screen in Mach 3, go to the Config tab on the menu bar and select 'Homing/Limits' from the list. Make sure you are not out of bounds with your settings.
4. Go to the Config tab on the menu bar and select 'Motor Tuning'. Your Velocity and Acceleration may need to be adjusted (motors too slow or too fast). They may be struggling to keep up.

Hope something I suggested helps,
Roger

Re: "Reference All" Jitters in Motors (M3)
« Reply #9 on: January 12, 2020, 12:33:09 PM »
David,
I don't know your level of expertise with CNC routers, but the 'Go to Zero' button on the Mach 3 main screen is NOT used for sending your X, Y,  and Z axes to the "Home" position. That button sends your axes to any one of the six Work Offsets (G54 -G59) you set up and select on the Offset screen. Mach 3 defaults to the G54 offset. So what ever value you have in the G54 Work Offset screen is where Mach 3 will send the router when you hit the Go to Zero button. Remember, the G54 offset value is ALWAYS referenced (measured) from the Machine Zero (Home position).
The Go to Zero button will also send your router to any location you set up for "Part Zero"  (X=0, Y=0, Z=0) on your work piece (wood). Part Zero is usually located at the lower left-hand corner of your work piece. Once you move your three axes to that corner and "zero out" the X, Y, and Z DROs (Digital Read Out) in Mach 3, the Go to Home button will go to that position automatically every time you hit that button - as long as you start at the HOME position.
Ok, so don't use the Go to Zero button for Homing.
(Sorry for being so long winded)
Now, it's the G28 X0 Y0 Z0 G-code command that will send any CNC router to the Home position. Most G-code programs will have the G28 command at some point in the program to raise the Z-Axis first, then the X and Y axes.
You can see this in action by going to the MDI screen and typing the following:
(Make sure all fixtures and clamps are out of the way.)

G28 X0 Y0 Z0  (Rapid movement)
or
G28 Z0 (hit Enter)
G28 X0 (hit Enter)
G28 Y0 (hit Enter)
If you get a hand held "Pendant", you can set it up (OEM codes) so when you hit the Home button on the pendant it will automatically send your router to the Home position. The OEM codes also work in "Script" files.

Let's get back to your problem. Here are a few suggestions:
1. Go to the Config tab on the menu bar and select 'Homing/Limits' from the list. You should have all green check marks under the heading 'Auto Zero' column. Also, play with the Speed percent setting. It may be too slow/fast.
2. Go to the Config tab on the menu bar and select 'Safe Z setup'. You should have  a check mark next to 'Allow Safe Z moves'.
3.If you have the 'Soft Limits'  button turned on (green) on the main screen in Mach 3, go to the Config tab on the menu bar and select 'Homing/Limits' from the list. Make sure you are not out of bounds with your settings.
4. Go to the Config tab on the menu bar and select 'Motor Tuning'. Your Velocity and Acceleration may need to be adjusted (motors too slow or too fast). They may be struggling to keep up.

Hope something I suggested helps,
Roger



Thanks for your reply, I will give this all a try and report back

Yesterday I tried updating M3 to the latest and re-loading my xml for my machine. It solved all the ref all home issues, but now has an issue with the Z axis when slow jogging it will move much more rapid and sometimes continue to move when the “up down” keys are let released. It will sometimes stop mid move when jogging and you can hear the motor make a higher pitch noise, and then stop, lastly a watchdog warning will pop up in Mach when this happens.

So I reverted back to the r3.00 version, ez-router mentioned I should update my Mach to the update ending in .062 which I believe was what I was on. Should I update again and start trouble shooting from that version? It did solve the issues with the y axis which gives me hope...

Thanks for your time

David