Hello Guest it is December 08, 2021, 02:48:55 AM

Author Topic: XHC Pendant WHB04B-4  (Read 4185 times)

0 Members and 1 Guest are viewing this topic.

XHC Pendant WHB04B-4
« on: December 26, 2019, 09:32:05 AM »
Good Morning.
I received a new pendant as a Christmas present, and have a couple of setup questions.  I have gone thru the manual, and have set up all the buttons as shown on page 13. However I do not understand what is supposed to go in all the button windows for "Custom OEM Code #1" (also #2), including what is supposed to go into all the associated Macro # fields. Assistance will be welcomed as I'm currently stumped. I have attached a snapshot to show how far I've gotten (not far LOL). Forgot to add, I'm on MACH3.....
Thanks, Henri Monnier - cnc@themonniers.com
« Last Edit: December 26, 2019, 09:37:02 AM by hmonnier »
Re: XHC Pendant WHB04B-4
« Reply #1 on: December 27, 2019, 03:19:00 PM »
After a lot of playing around and trying things, I've discovered that if in the config, if i set a button macro to one in the list, it seems to function fine. However if I select a custom macro, and put that number in the macro box for that macro, it does not work. So my suspicion is that i have no idea what code number I should be putting in that custom oem code box. In the manual, it shows a code of 1001, but I have no idea if that is a good number or not. Can one of you out there that have and are using this pendant, could you help me out a bit solving this little issue????
Thanks, Henri Monnier - cnc@themonniers.com for faster response.....
Re: XHC Pendant WHB04B-4
« Reply #2 on: December 31, 2019, 04:45:44 AM »

I have the same product installed on my newly made CNC mill, and I have the same problem...
as always chinese manuals are useless (or not specific enough), so I'm stuck like you!

I was thinking if there may be a list of mach3 operation codes that may fit in those macro boxes... but I'm completely new with the software too... so I'm just wondering.....

Anyway, for now I have bigger problems to face.... sometimes while jogging with the pendant the mach3 software get stuck and the axis I am moving continues to move even if I stop turning the wheel! I need to push the reset button for stopping the machine, as none of the other buttons in mach3 work....

Bye Adrian

Re: XHC Pendant WHB04B-4
« Reply #3 on: December 31, 2019, 06:04:02 AM »

sometimes while jogging with the pendant the mach3 software get stuck and the axis I am moving continues to move even if I stop turning the wheel!

If you spin the wheel fast enough the machine can't keep up so the pulses get stored up, so even when the wheel stops the
pulses in the buffer cause the machine to move until the buffer is emptied. This is normal behavior. You need to either not
spin the wheel so fast OR decrease the step size so that the machine never lags behind OR increase the speed of the machine
so that it never lags behind and therefore no pulses get pushed into the buffer.

My solution was the second option, namely reduce the step size. I had originally set the maximum movement per click at 1mm.
I had the problem you describe, that is the machine would carry on moving even after I stopped. I reduced that down to
0.5mm per click. Now I can still make it happen if I spin the wheel really really fast, but you have to be pretty determined
to do it. Mostly I can turn the wheel and the machine keeps pace at a good and comfortable speed without overrun. Problem solved.

My wife left with my best friend...
     and I miss him!
Re: XHC Pendant WHB04B-4
« Reply #4 on: December 31, 2019, 06:38:25 AM »
I thank you both for your comments. I found that it also interfered with my SmoothStepper, causing the stepper to alarm. Once that happened, in order to reset the stepper, you had to shut MACH3 down, then restart it from scratch. Not a big deal if you are not in the middle of a carve, but a potential pain if you are. I also noticed that there were also some impacts to buttons on the 2010 Screenset that I use; the buttons no longer worked if you selected them with the mouse. Also the inadequate manual and no support (they ignored messages sent, I had return notifications set, so I know they received them; multiple published contact addresses) from the manufacturer, lead me to abandon my use of the pendant.

I had wished this pendant would have been an asset to operation, but after spending almost 5 or 6
days of frustration trying to get the pendant working satisfactorily, I flat gave up and returned it to Amazon.

I have returned to using my old wired ShuttlePro, which functions fine with no impacts to screen buttons, or the stepper. Hopefully it will not crap out, since it will be difficult to find another....
Re: XHC Pendant WHB04B-4
« Reply #5 on: December 31, 2019, 08:35:16 AM »

regarding the pendant performance, I doubt on its reliability too.
while jogging sometimes the axis I'm working with, becomes crazy and moves forward or back at high speed for fractions of a second then returms to move properly....
it's not a question of speed, as it happens also when turning showly the wheel, and the switch is set to 0.1/0.01%.

I think you made the right choise to give it back to Amazon.... I can't do it as I bought on Aliexpress at the beginning of the year... but I may put it on sale!!
I would like to use a simple wired PG, but my controller card (the XHC MK3-ET ethernet) does not have the inputs needed... I wonder if I may use another expansion card as interface for controlling it....

Like Craig said, it may be a question of buffer (thank you for the hint, Craig!) but I also wonder if other hardware/software plug-ins may cause the system to be unstable.
The motor speed is set so that I can move the axis by 0.1mm/wheel pulse.


is there a way to see if a buffer was made and the system is waiting to end the sequence?
I am pretty new on the mach3 so I don't know the meanng of many error messages.... but this is a list of the errors I last saved:
Sun - 18:06:54 ---Program Startup
Sun - 18:06:56 ---ReConfiguration Estop.
Sun - 18:07:01 ---Device IO Triggered.
Sun - 18:07:59 ---Device is busy!
Sun - 18:08:10 ---Mach3 is jogging!
Sun - 18:08:36 ---Device is busy!
Sun - 18:08:36 ---Mach3 is jogging!
Sun - 18:08:38 ---Device is busy!
Sun - 18:08:38 ---Mach3 is jogging!
Sun - 18:08:46 ---Device is busy!
Sun - 18:08:47 ---Mach3 is jogging!
Sun - 18:08:51 ---Device is busy!
Sun - 18:08:53 ---Mach3 is jogging!
Sun - 18:08:59 ---Device is busy!
Sun - 18:09:02 ---Mach3 is jogging!
Sun - 18:09:55 ---Device is busy!
Sun - 18:10:53 ---Mach3 is jogging!
Sun - 18:11:25 ---Device is busy!
Sun - 18:12:02 ---Mach3 is jogging!
Sun - 18:14:12 ---Device is busy!
Sun - 18:14:29 ---Mach3 is jogging!
Sun - 18:18:42 ---Device is busy!
Sun - 18:18:46 ---Mach3 is jogging!
Sun - 18:18:56 ---Device is busy!
Sun - 18:18:56 ---Mach3 is jogging!
Sun - 18:19:20 ---Device is busy!
Sun - 18:19:21 ---Mach3 is jogging!
Sun - 18:19:34 ---Device is busy!
Sun - 18:20:12 ---Nothing to Feedhold
Sun - 18:20:15 ---Nothing to Feedhold
Sun - 18:20:15 ---Waiting for sequence to End!
Sun - 18:20:18 ---Nothing to Feedhold
Sun - 18:20:18 ---Nothing to Feedhold
Sun - 18:20:20 ---Nothing to Feedhold
Sun - 18:20:33 ---Nothing to Feedhold
Sun - 18:20:35 ---EStop Button Pressed.
Sun - 18:20:43 ---EStop Button Pressed.
Sun - 18:20:47 ---Note: Cycle Pause in effect..No jogging or Reverse!!
Sun - 18:21:36 ---EStop Button Pressed.

Estop pressed is when the axis continues to move for long after I stopped turning the wheel....
so I doubt such a buffer was stored.

When this problem happens also other errors are reported, but I don't remember them now....

Do you know the meaning of "device is busy"?
which device could it talk about?
the control card, the PC, or even the pendant?

I have one last question I hope you guys can help me with:
sometimes if I want to move an axis left, it moves right for an instant, then moves left!
it also happens the opposite.
my system is made from an old japanese chip mounter, so X and Y axis are controlled by Yaskawa servo drives and motors, while the newly installed Z axis has a closed loop step motor;
The signals given by the controller should be DIR first and then PULS so that the motor can rotate accordingly;
taking a look at signals with my 2 channel oscillocope I found that both DIR and PULS start emitting signals at the same time so I guess the Yaskawa driver may sometimes fail to move to the right direction (even for a moment)...

Do you know if the vawes kind and times are set by mach3 software or it is the controller to manage this thing?
I know it's a pretty electronic question (which I'm more familiar with...) but you know it ;)

Re: XHC Pendant WHB04B-4
« Reply #6 on: December 31, 2019, 09:12:22 AM »
I am by no means an expert on MACH3, but I've been using it since about 2009. I do not use one of the newer versions, but an older version (Version R3.043.066), since there were some issues with some of the newer versions back then. Perhaps they have been corrected, but for me, if it ain't broke, I ain't messing with it. There also was an issue a while back (2 years or so?), where Microsoft, issued an update, that 'broke' MACH3. Once that got corrected (think that was by MS), the CNC PC's that were connected to the net were disconnected, and will never be reconnected. All app updates, Aspire, etc., are only done via CD of USB.

It's a shame that the WHB04B seems to have some really solvable issues. The concept is great, the packaging is great, but more attention needs to be directed at improving the interface between itself and the cnc machine.  As for pendants, you might consider the ShuttlePro. I have been using them since 2011, and they have never hiccuped nor has MACH3 or the SmoothStepper. I'd love to have a wireless one, but am not willing to spring at the price of the other ones that are out there.

Henri Monnier - cnc@themonniers.com
« Last Edit: December 31, 2019, 09:15:58 AM by hmonnier »
Re: XHC Pendant WHB04B-4
« Reply #7 on: December 31, 2019, 11:22:55 AM »

I'm using exactly the same software version, the 3.043.066.....

today I wanted to test some parts of my system, so the first try was to change PC;
the currently installed is a 10 year old 2 core at 3Ghz with SSD and 2Gb RAM, so I tested the Mach3 on a new very performing PC....
that was the perfect try!! it came clearly out that the problem is the Pendant!!!!!
maybe the pendant setup....
using it the axis now moves very badly (worse than before) and lots of errors appear on mach3 status display.
It is lakely that the busy device is the pendant!

using the arrows on the keyboard the axis moves smoothly, it never misses a step, and motors never get crazy like they did before.

all the other questions about axis drive signals are useless now, as the system now WORKS!

I will look for a different pendant and sell this one.....

have a great new year eve, regards

Re: XHC Pendant WHB04B-4
« Reply #8 on: December 31, 2019, 12:48:06 PM »
XHC has a long reputation as being buggy, both their controllers and their pendants, and you can forget trying to get
XHC to help. They've already got your money and they just don't care.

I use a VistaCNC P1A pendant and have done for years. It worked perfectly with Mach3 and then with Mach4 for the last five
years, and they support their products.

My wife left with my best friend...
     and I miss him!
Re: XHC Pendant WHB04B-4
« Reply #9 on: December 31, 2019, 02:27:05 PM »
You are right Craig, I realize that now that I have been working on Xhc stuff for the past few months....
I saw a Vista CNC pendant video on YouTube, it works great, it's very precise.
The problem will be have it shipped to Italy..... I hope I can find it somewhere in Europe....