Hello Guest it is May 16, 2021, 02:21:54 PM

Author Topic: Setting back off distance from homing switches in Mach 3  (Read 1359 times)

0 Members and 1 Guest are viewing this topic.

Setting back off distance from homing switches in Mach 3
« on: November 10, 2019, 06:38:17 AM »
So where do I set the back off distance to keep my machine from homing on the limit switches under Mach3?

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Setting back off distance from homing switches in Mach 3
« Reply #1 on: November 10, 2019, 06:49:28 AM »
Within Mach3 there is no setting for limit switches back-off distance - the axis will only back-off until the limit switch changes state.
You can then use an Offset or, within the Button, use VB to set the axis position/s of your choice.
« Last Edit: November 10, 2019, 06:55:53 AM by Tweakie.CNC »
KEEP SAFE !
Re: Setting back off distance from homing switches in Mach 3
« Reply #2 on: November 10, 2019, 07:38:42 AM »
That's just it. It's not backing off at all. When it homes it stays against the switch

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Setting back off distance from homing switches in Mach 3
« Reply #3 on: November 10, 2019, 07:46:36 AM »
That's just it. It's not backing off at all. When it homes it stays against the switch

Then you have a problem with your Mach3 installation which could be...
Software, in which case re-install Mach.
Hardware, which could be electrical noise causing a false signal or a poor quality switch.

Try increasing the Debounce setting in Config / General Config and see if that makes a difference.

Tweakie.
KEEP SAFE !
Re: Setting back off distance from homing switches in Mach 3
« Reply #4 on: November 10, 2019, 08:55:44 AM »
what controller are you using? if its the HXC goto plugin control / Hxc Ncpod config and you have an option for homing pull off. It sets the distance for the duel stage homing and  also like you want the offset distance after homing. Hope this helps
My only fear is my wife will find out how much I spend on my hobby.
Re: Setting back off distance from homing switches in Mach 3
« Reply #5 on: November 14, 2019, 02:45:46 PM »
Ok, reinstalling Mach3 fixed the issue.

Offline Tweakie.CNC

*
  • *
  •  8,706 8,706
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Setting back off distance from homing switches in Mach 3
« Reply #6 on: November 15, 2019, 02:09:46 AM »
 ;)
KEEP SAFE !