Hello Guest it is November 29, 2020, 02:03:42 PM

Author Topic: Encoder config on lathe CNC4PC ENC03  (Read 729 times)

0 Members and 1 Guest are viewing this topic.

Encoder config on lathe CNC4PC ENC03
« on: September 23, 2019, 05:17:22 PM »
Hi all,

I am new to all this and trying to get a mini lathe up and running with Mach 4.
I have a pokeys 57e I have it plugged in to the port labeled encoder. However, I cannot get the encoder to display rpm in Mach 4. I wired the C 27 per the attached spreadsheet. I set it up in mach 4 config per the attached pdf.

Any insight in to my problem?

Thanks,

Dale Grice
Re: Encoder config on lathe CNC4PC ENC03
« Reply #1 on: September 25, 2019, 06:30:36 AM »
Hi Dale,
I'm in the same boat as you in that I can not get the encoder, a AMT103, to display or process the RPM pulse in the ENCODER(Lathe) mode. I get very steady and very accurate reading in the INDEX(Lathe) mode only. I also get very clean A, B & INDEX scoped pulses on the RJ45_7 pins and have been trying PK Pins 8, 12 & 13 as shown in the Pokeys Manual. My next step is to hard wire the PK pins direct.
« Last Edit: September 25, 2019, 06:33:27 AM by bpratl »
Re: Encoder config on lathe CNC4PC ENC03
« Reply #2 on: September 30, 2019, 06:01:35 PM »
Hi bpratl,

I got mine to work in Encoder(Lathe) mode. Happened to be a bad connection inside my box that houses the pokeyes.

I also noted that my enc03 is 500 pulses per revolution.

Let me know if you still have a problem and I will gather some screen shots of my config.

Dale
Re: Encoder config on lathe CNC4PC ENC03
« Reply #3 on: October 01, 2019, 04:33:20 AM »
Hi Dale,
That's good news. What Pokeys Device are you using? I am using CNC4PC M16D motherboard with a 57e board and I was just told that it has a configuration problem for the encoder inputs so I'm waiting for a answer from them. That would be great if you could send me your configuration setup and screen shots. Thanks.
Bob
Re: Encoder config on lathe CNC4PC ENC03
« Reply #4 on: October 02, 2019, 05:49:27 PM »
I am using CNC4PC M16D motherboard with a 57e board. See the attached PDF. My speed varies a little. Like 196 to 204. Not sure if it is the lathe or the slightly wobbly wheel on the encoder.

Dale
Re: Encoder config on lathe CNC4PC ENC03
« Reply #5 on: October 02, 2019, 09:00:36 PM »
Hi Dale,
Thanks a million. I will set up Pokeys the same as your configuration tomorrow and I hope that it works.
Thanks again.
Bob
Re: Encoder config on lathe CNC4PC ENC03
« Reply #6 on: October 04, 2019, 06:09:20 PM »
Attached pulse engine config.
Re: Encoder config on lathe CNC4PC ENC03
« Reply #7 on: October 05, 2019, 03:43:19 AM »
Thanks Dale. I'm trying to rule out all variables.
Re: Encoder config on lathe CNC4PC ENC03
« Reply #8 on: January 25, 2020, 05:59:12 PM »
oh boy fellas, I have been looking forever for information for setting up the M16D pkeys57E spindle encoder for rigid tapping on my cnc mill and there just isnt any help out there. I need to know how to configure ports and pins for the encoder, and get synchronized spindle and z axis. and I would like to set up a lathe profile and do threading and lathe on my virticle mill as well. I will certainly be looking this info over, and if you have any other help, I would surely appreciate it. thank you.
Re: Encoder config on lathe CNC4PC ENC03
« Reply #9 on: March 13, 2020, 03:32:28 PM »
I hope your not using a servo motor as a spindle motor .Do you have the index pin13 enabled in the inputs.