Hello Guest it is October 20, 2019, 05:32:49 AM

Author Topic: Plasma ignition and stop lag problem  (Read 231 times)

0 Members and 1 Guest are viewing this topic.

Plasma ignition and stop lag problem
« on: July 05, 2019, 04:26:52 PM »
Hello, I come to you because I have a problem and I think it's problably due to my Mach3 configuration. When I start a plasma cutting, the plasma start and stay a moment at the same place before cutting, and it stop before the end of the cutting. I have already set my 4 parameters for Dwell in "Spindle setup" at 0, but nothing change. I think my GCODE is ok, but I let you invoice, just in case.

Thank you !

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Plasma ignition and stop lag problem
« Reply #1 on: July 06, 2019, 02:51:05 AM »
there is a G04 in your GCode witch causes the delay


...
Z1
Z0
M3
G4P1
G3X-0.8I-1.3J-50.4F2000
...
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Plasma ignition and stop lag problem
« Reply #2 on: July 06, 2019, 03:13:20 AM »
Thanks for your answer, I've tried to delete all G4P1, the cycle is smallest but I have always this lag. For example, the ignition start between 500ms and 1s before the torch moving, and the plasma stop before the end of the move. As if we have a time lag, in advance to the movement

PS : Sorry if my English is bad

Online Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Plasma ignition and stop lag problem
« Reply #3 on: July 06, 2019, 05:42:07 AM »
The M3 / M5 command set have an inherent delay. To overcome this issue the M11Px / M10Px command set was introduced, initially for Laser control but it is now commonly used with Plasma (it only switches the output pin (Output#) at the instant of axis movement). There are a few more details here; http://hobbycncart.com/publ/cikkek/mach3_temaju_cikkek/switching_a_laser_under_mach_control/8-1-0-29


Assuming you are using the PC’s LPT Parallel Port or a motion controller that supports the M11/M10 command set then…
If you determine which Output# you are using to switch your torch ON / OFF then you can replace all M3 commands with M11Px and M4 commands with M10Px (where x = the Output# mentioned earlier).

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline TPS

*
  •  1,389 1,389
    • View Profile
Re: Plasma ignition and stop lag problem
« Reply #4 on: July 06, 2019, 06:59:30 AM »
if your run in Plasma mode with THC on, it will allways wait until torch on Signal Shows up.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: Plasma ignition and stop lag problem
« Reply #5 on: July 07, 2019, 07:08:06 AM »
Hello, thank you for your answers, I come with some (bad) news
I've tried the M11P1/M10P1 but nothing happened, maybe my controller card is not suitable for this command ? I have a NVEM V2 ethernet controller
Maybe I have to configure Mach3 differently with these commands ?

I don't have the THC with my plasma so the option is disabled

I've also tried to play with the delay in Spindle options but I don't understand how the delay "CW Spindle DOWN" work, I thought I can play with it to delay the stopping of the plasma but nothing happened, the plasma stop earlier than I want

Many thank for your help
Re: Plasma ignition and stop lag problem
« Reply #6 on: July 07, 2019, 08:02:35 AM »
Hi,

Quote
I have a NVEM V2 ethernet controller
Maybe I have to configure Mach3 differently with these commands ?

No, unfortunately that controller does not support those commands, there is no workaround or manipulation you can
do in Mach3 that will make that controller support those commands. It is a known and recurring issue that Chinese controllers
that, at best, support a subset of Mach commands, in this case not including M10, M11.

You either revert to a parallel port, assuming you have a Windows 7 or earlier 32bit PC or get a decent US or European
motion controller like an Ethernet SmoothStepper, a UC300 or a 57CNC.

Craig
My wife left with my best friend...
     and I miss him!

Online Tweakie.CNC

*
  • *
  •  7,951 7,951
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Plasma ignition and stop lag problem
« Reply #7 on: July 07, 2019, 08:11:11 AM »
Hi Jeremy,

Unfortunately Novusun is one of the businesses listed in our Hall of Shame for Mach3 Licence violation. As a result this forum does not support assistance with any of it's products unless you are a genuine Mach3 or Mach4 license holder.

This thread referrers; https://www.machsupport.com/forum/index.php?topic=24331.msg238650#msg238650

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Plasma ignition and stop lag problem
« Reply #8 on: July 07, 2019, 08:15:15 AM »
Hi,
so not only does the controller not work but they are quite content to peddle pirate copies of Mach?

The Chinese must love us......'look the stupid white man buys our s*********ty stuff and we get away with it'.

Craig
My wife left with my best friend...
     and I miss him!
Re: Plasma ignition and stop lag problem
« Reply #9 on: July 07, 2019, 08:26:45 AM »
Alright I understand, I've choose this one because I have interferences with my older one, probably due to the USB connection

So let's choose a new controller !

Thank for your help