Hello Guest it is February 24, 2020, 01:20:52 PM

Author Topic: LED not showing with transparency  (Read 607 times)

0 Members and 1 Guest are viewing this topic.

LED not showing with transparency
« on: June 12, 2019, 09:20:59 PM »
Hi All,

I have made some LED buttons in Real Draw and exported them as PNG's with transparency, in Machscreen they look good with a clear background but when I load the screen into Mach3 I get a black background not the transparency.

Can you give me any idea what I may have done wrong.

Thanks
YP

Offline ger21

*
  • *
  •  6,279 6,279
    • View Profile
    • The CNC Woodworker
Re: LED not showing with transparency
« Reply #1 on: June 12, 2019, 10:02:04 PM »
Can you upload the files?
Usually, a black background means the order is not correct. Maybe the LED on top of the button?
You need a 100% transparent image for the button. The LED doesn't need any transparency. Button on top.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html

Offline TPS

*
  •  1,480 1,480
    • View Profile
Re: LED not showing with transparency
« Reply #2 on: June 13, 2019, 02:09:08 PM »
or use a tranparent button
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.
Re: LED not showing with transparency
« Reply #3 on: June 16, 2019, 02:17:44 PM »
Thanks for the help so far but I need a bit more.  I have the LED issue sorted but no matter what I do I can not get the toolpath window on top of the background image.

The background image is on page 0 and the toolpath is on page 3 and is hidden behind the background.  I have tried in Screen4 to move the images to back and had it in Machscreen but nothing seems to work.

Any help much received.

Thanks
YP
Re: LED not showing with transparency
« Reply #4 on: June 16, 2019, 02:39:39 PM »
Hi YP

with MachScreen make sure "Multiple selection" is checked (second icon from the right in the toolbar. If you hit the led, a window opens up showing the components in the current order. Change order by tragging the LED up or down to your desired order.

Klaus
The brain isn't a soap, it doesn't shrink when used.
Re: LED not showing with transparency
« Reply #5 on: June 16, 2019, 02:56:12 PM »
Hi Klaus,

thank you for the reply, I have the LED sorted.

My problem now is how do I select the global background image and the tool path on page 3 to make the toolpath come to the front?

Thanks,
YP

Offline ger21

*
  • *
  •  6,279 6,279
    • View Profile
    • The CNC Woodworker
Re: LED not showing with transparency
« Reply #6 on: June 16, 2019, 09:53:07 PM »
I believe that anything on Page 0 will always be on top?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: LED not showing with transparency
« Reply #7 on: June 17, 2019, 05:50:28 AM »
Thank you Klaus for the PM and getting me sorted.
Re: LED not showing with transparency
« Reply #8 on: June 17, 2019, 07:40:54 AM »
Hi ger21

you are right, with the exception images on page 0 stay in background

Klaus
The brain isn't a soap, it doesn't shrink when used.