Hello Guest it is July 06, 2020, 11:11:50 PM

Author Topic: mach3 milling errors  (Read 724 times)

0 Members and 1 Guest are viewing this topic.

mach3 milling errors
« on: June 08, 2019, 06:04:11 PM »
I tried many different Mach3 settings but my machine does not work as expected. The machine is a Shapeoko 3 diy, not a Carbide 3D kit, but it has 30kgf motors driven by DMA860h drivers, HDZ Z axis, heavy duty wheels and eccentrics from BeaverCNC, a 500w temporary spindle to be replaced soon by a 2.2kw water cooled. The controller is of industrial strength 500khz ethernet Nevex NX-max 4 axis unit with a Mach3 plugin. Homing switches are not connected right now but soft limits are working ok. The machine seems to ride well on the aluminum profiles, belts are well tightened, motors are set at 3.0 amperes, motor tuning from mach3 settings page seems to be right on spot.  Any milling that I attempt looks like the machine is adding steps to the negative sides of X and Y axes, ruining the work. There is a Picture showing work done on my Shapeoko 2 versus two attempts on this Shapeoko 3 lookalike. Any ideas on what is wrong?
Re: mach3 milling errors
« Reply #1 on: June 08, 2019, 06:31:23 PM »
Hi,
this is a classic case of one or more axes losing steps.

Stepper motors lose torque the faster they go. A given stepper may have 400oz.in holding torque but only 150oz.in
at 500 rpm and 40oz.in at 1000 rpm. Yes, you read that correctly.....only 10% of its initial torque at 1000 rpm.

First time buyer of steppers tend to buy based on holding torque alone. This is a mistake. The inductance of a stepper
determines how badly it will lose torque as the speed gets up. Thus a 500oz.in stepper with high inductance might have
only 50oz.in at 1000 rpm whereas a 400oz.in low inductance motor might retain 100oz.in at 1000 rpm. Believe it or not
the 400 oz.in motor is the better unit.

Can you post the model of the steppers you have used?

One way to combat the loss of torque as speed goes up is to use a higher voltage supply and driver. What voltage supply
are you using? The drivers (DMA860h) are advertised as being good for 80V so I would have a supply of 72V at least.

In the first instance you need to reduce the maximum velocity  and maximum acceleration of the machine in your motor
tuning to a very slow rate and then slowly increase the velocity (to start with) until you start to lose steps, then back
off 25%. Do the same with acceleration.

Craig
My wife left with my best friend...
     and I miss him!
Re: mach3 milling errors
« Reply #2 on: June 09, 2019, 08:18:49 AM »
Hello... thank you for the reply!  All motors are wotiom ws23-0300-30-4 and the dma860h are fed from a 60VAC toroidal transformer rated at 30 amperes.
Re: mach3 milling errors
« Reply #3 on: June 09, 2019, 09:25:56 AM »
I lowered the speed and acceleration to 400 and 40, respectively, for axises X and Y. The jogging is appalingly slow. Tried the same milling again, it seems to go well for the first cuts but the same behaviour, a deviation to the negative sides of X and Y, looks the same. The cuts are not precise and do not reflect similarity with the expected result. 
« Last Edit: June 10, 2019, 09:06:49 AM by Graham Waterworth »
Re: mach3 milling errors
« Reply #4 on: June 09, 2019, 02:18:00 PM »
Hi,
the probability is that you have the jog rate set to only 6% of the traverse rate, its is set at 6% when Mach fires up.

Reduce the max speed and acceleration by half again and then re-try.

What is the inductance of your motors?
What is the voltage of your driver supply?

Craig
My wife left with my best friend...
     and I miss him!
Re: mach3 milling errors
« Reply #5 on: June 09, 2019, 04:23:06 PM »
Hello Craig...   jog rate is set to 100% and as I lower the speed and accelleration on motor tuning, the slower the machine moves. I attached the technical specs for the motor. I also tried changing other settings in mach3...   tried to unmark all CV settings... no change...   tried to set motion mode to exact stop... no change... tried to change distance mode from absolute to incremental, machine went crazy...   will try lowering speed and acceleration to 200 and 20...   Voltage input to drivers is 60 VAC from a toroidal transformer rated at 30a. Inductance 6.5 mH.
« Last Edit: June 09, 2019, 04:29:51 PM by pcrego »
Re: mach3 milling errors
« Reply #6 on: June 09, 2019, 05:00:09 PM »
At 200 velocity and 20 acceleration, machines moves too slowly but still cuts profiles all wrong...  same result as the other attempts... carves the small profiles out of alignment and makes the same deviation to the negative sides of the X and Y axes. I tried X-carve post processor, Shapeoko post processor and Mach3 Arc postprocessor... having to change the some to .txt files, but the results are wrong the same. I wonder if there is a basic flaw in electronics wiring or even a defective card or driver...   I believe this was not supposed to give me such a headache.... 
Re: mach3 milling errors
« Reply #7 on: June 10, 2019, 03:05:38 AM »
Hi,
you have too many variables going on.

I'm beginning to think that your steps/per are wrong.

Do you use inches or mm?

If you zero the Xaxis and MDI:

g1 x100 f200 (this assumes mm units)

does the axis move exactly 100mm? Repeat the test with Y and Z axes.

Craig
My wife left with my best friend...
     and I miss him!

Offline Tweakie.CNC

*
  • *
  •  8,347 8,347
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: mach3 milling errors
« Reply #8 on: June 10, 2019, 03:36:17 AM »
Hi pcrego,

Do you have a Mach3 license registered in your own name or the name of your company ?

Tweakie.
KEEP SAFE !
Re: mach3 milling errors
« Reply #9 on: June 10, 2019, 08:23:20 AM »
Tweakie, my mach3 license is registered to Paulo Cesar Rego 73NZ.  I purchased it less than a month ago, when the machine was ready for some testing.

Craig, I repeated the commands for all axises and the results are very consistent. Movement stops dead on where it is supposed to.  I have done this tuning many times, at different speeds and accelerations, and I found that 39.95 for X and 40.3 for Y gives me the more accurate movements, even when testing movement at 700mm. The Z axis is set at 320, per BeaverCNC calculations and it is also accurate. Because my problems show at the xY coordinates I did not worry yet about Z when milling...