Hello Guest it is July 19, 2019, 05:27:22 PM

Author Topic: Loadfile problems/questions  (Read 2499 times)

0 Members and 1 Guest are viewing this topic.

Offline mhdale

*
  •  130 130
  • Knowledge is the Treasure.
    • View Profile
    • Black Dragon Technologies
Loadfile problems/questions
« on: August 27, 2007, 08:41:08 PM »
Hello All, hopefully Brian and or Art. I have this screen which has a button which loads a small file. (please bear in mind this is in the beginiing stages of testing)
The file is as follows:

;PROGRAM NAME -  SBABS5-30C Center Beam
;SPRUNG Control System G-CODE File
; **************  Do NOT ********************
; Run this G-CODE on a Normal CNC Machine
;   Damage will Alomost Certainly occur
;============================================
; Verify Beam is LOADED & Ready Move M5 Module
;       and GRAB Beam From Staging Clamp
;                     Stage 1
G04 P5
M1050
; Move Beam to Position (Usually Drill Hole 1) Do not release
G01 Y150 F300
; Activate Drill Station
M1052
; Move Beam to Position (Usually Drill Hole 2) Do Not Release
G01 Y140 F300
; Activate Drill Station
M1052
; Set DONE Drill Sequence
M1053
; Move Beam to Macining Position - Clamp beam - Release M5 And move away 24 Inches
G01 Y100 F300
; Set Beam to Tilt 2 Position
M1056
; Wait for Haas to Finish
M1070
; Reset TILT to Zero
M1057
; Wait for Haas to Finish
M1070
; Perform Tilt 1
M1058
; Peform WB1 Tilt1 Capture
M1059
; Wait for Haas to Finish
M1070
; WB1 Tilt 1 Release
M1060
; Reset WB2 to Nuetral Position
M1061
; Wait for Haas to Finish
M1070
; Use WB1 M5 Module to Push Beam Out
M1065
; Finish Cycle
M1075
M02

This program loads when I click the button but seems to want to "run" the program as soon as it is loaded and it causes Mach to Crash. Now it may be that some of the macros have errors in them and I am tracking those down but I am a bit concerned over the program running through any suggestions? pointers?

Mike

Offline Graham Waterworth

*
  • *
  •  1,863 1,863
  • Yorkshire Dales, England
    • View Profile
Re: Loadfile problems/questions
« Reply #1 on: August 28, 2007, 01:41:29 AM »
Hi Mike,

all of your macro's need to have the statement :-

IF IsLoading() THEN
  Do nothing, Mach is working out the graphics
Else
  Your current code goes here
End if

Graham.
Never give up, time will pass, the cloud will clear, the sun will shine once more.

Offline mhdale

*
  •  130 130
  • Knowledge is the Treasure.
    • View Profile
    • Black Dragon Technologies
Re: Loadfile problems/questions
« Reply #2 on: August 28, 2007, 02:02:08 AM »
O, Well Thats something I havent heard before.... makes sense. Thanks Graham, I will put that in and see if that fixes it up. Thanks a great deal.

Mike