Hello Guest it is December 13, 2019, 04:55:00 AM

Author Topic: Homing Slave Axis  (Read 4747 times)

0 Members and 1 Guest are viewing this topic.

Homing Slave Axis
« on: August 22, 2007, 12:53:12 PM »
Hi, I use Mach3, in X have Slave axis when homing X the slave axis have no movement, only X is moved

Offline Greolt

*
  •  956 956
    • View Profile
Re: Homing Slave Axis
« Reply #1 on: August 22, 2007, 05:49:00 PM »
AlfredoG

Try checking the "Home Slave Axis with Master Axis" box on the general config page and see if the slave moves with the X axis then.

I know this may not be what you ultimately need but just see if it works.

Perhaps you could post your XML file so we can have a look.  What version of Mach are you using?

Greg
Re: Homing Slave Axis
« Reply #2 on: August 22, 2007, 11:16:44 PM »
i use Mach3 version r2.00.065, both axis moves in any command, only is stopped when press reference button for homing

Offline Greolt

*
  •  956 956
    • View Profile
Re: Homing Slave Axis
« Reply #3 on: August 22, 2007, 11:41:33 PM »
AlfredoG

Are you using the printer port or ncPod or something else?

Do you have homing switches on both sides? Or only one on the axis?

If you have two, is one of them already active when you press home?  Look on the diagnostics page.

If you only have one then the "Home Slave with Master Axis" setting should be checked.

Although the "Home Slave with Master Axis" setting is not on that version of Mach.

I would recommend updating to the current lockdown version.  I think it is 2.4

Greg
Re: Homing Slave Axis
« Reply #4 on: August 23, 2007, 09:46:14 AM »
To home both at the same time you need to change the code of the Ref to the following

Refcombination(9)

The vlaue that you pass is done by adding the following
x=1
y=2
z=4
a=8
b=16
c=32

So as you can see in my example I am Refing the X and A at the same time :)

Hopet hat helps
Brian

Fixing problems one post at a time ;)

www.newfangledsolutions.com
www.machsupport.com