Hello Guest it is December 15, 2019, 08:46:05 AM

Author Topic: Mach 4 homing erroer  (Read 199 times)

0 Members and 1 Guest are viewing this topic.

Offline Vivek

*
  •  12 12
    • View Profile
Mach 4 homing erroer
« on: February 28, 2019, 09:48:46 AM »
Hi,

I get a homing error when I press the home button. "###Homing Error###. Motor:2 is not enabled" and I really don't know what I need to do in order to fix that.

Sincerely,

Vivek
Re: Mach 4 homing erroer
« Reply #1 on: February 28, 2019, 06:44:28 PM »
Hi,
that error is telling you that the code executing the homing routine is asking for the axis powered by motor 2 to drive
to its home switch. Clearly you do not have a motor 2.

Most people with a mill or router assign:
motor 0=X axis
motor 1=Y axis
motor 2=Z axis

With a lathe:
motor 0=X axis
motor 1=Z axis

and there is NO motor 2.

Two ways to skin this cat:
1) In configure/Control/Axis_Mapping assign a motor 2, even if you don't have one.....and set that axis to 'Home in Place'
   in the Configure/Control/Homing-Softlimits page
2) In the Configure/Control/Homing-Softlimits page assign '0' the Home_order of the unused axis.

Craig

My wife left with my best friend...
     and I miss him!

Offline smurph

*
  • *
  •  1,161 1,161
  • "That there... that's an RV."
    • View Profile
Re: Mach 4 homing erroer
« Reply #2 on: February 28, 2019, 07:39:36 PM »
Also check

Configure->Control->Motors  And make sure the check boxes are checked by all of the motors that you use.

Steve

Offline Vivek

*
  •  12 12
    • View Profile
Re: Mach 4 homing erroer
« Reply #3 on: March 04, 2019, 10:46:08 AM »
I am replacing all the motors and drive and pretty much stripping down my machine. I have two motors on x axis, one on y and z axis each. I am using Hicon controller. I have checked all the boxes making sure the motor have been enabled. I can move the motors using the jog feature.  It still says motor 0 and motor 2 not not enabled when I press the home button. Would it help more if I send the pictures of all my settings.

Vivek