Hello Guest it is April 13, 2021, 09:44:37 PM

Author Topic: Spindle Motor problems  (Read 318 times)

0 Members and 1 Guest are viewing this topic.

Offline jtd

*
  •  5 5
    • View Profile
Spindle Motor problems
« on: January 31, 2019, 04:43:02 PM »
I have Little machine shop hi-Torque mini lathe with Pokeys57 controller.  For some reason my spindle speed max speed is set at 1000 rpm.  I can go into MIDI and shift to spindle Speed to spindle Speed (G97) and increase speed up to 2000 rpm no problem.  The CSS (G96) it is limited to 1000 rpm (x axis is at 0).  It was working couple weeks ago fine. 
  I only found one location under mach Configuration spindle tab that had any setting and it is set at 2500 rpm. 

Is there another setting somewhere are can some one venture to guess if I have a failure somewhere.

  Thank you!
Re: Spindle Motor problems
« Reply #1 on: January 31, 2019, 04:47:11 PM »
Do you have a G50 Max/Min RPM Limit set?
Page 36 of the Lathe Programming manual:

Format: G50 S__ Q__
In this format S specifies the maximum spindle speed and Q specifies the minimum speed.

Put in a G50 S2500 and see if that changes anything.
Chad Byrd

Offline jtd

*
  •  5 5
    • View Profile
Re: Spindle Motor problems
« Reply #2 on: January 31, 2019, 05:19:09 PM »
Thank you!  It took care of part of it but the Canned Cycles is placing the G50 command in the code.  I looked in the setting for canned cycles and there is nothing about max speed.

 I found it! Under the advanced settings in each of operations tabs it talks about G50. 

I appreciate the help and sorry for the Brain Fart moment