Hello Guest it is October 22, 2019, 05:32:18 AM

Author Topic: Motors turn with G code but not with keyboard...Help!  (Read 430 times)

0 Members and 1 Guest are viewing this topic.

Motors turn with G code but not with keyboard...Help!
« on: December 09, 2018, 05:17:25 PM »
Mach 3 running G code fine but can not jog with the keyboard.

Ports-Pins settings must be right cause the G code will turn the motors.

Keyboard edits code so it must be working right.

The keyboard just aint talking to the motors.

Any ideas??

Thanks

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Motors turn with G code but not with keyboard...Help!
« Reply #1 on: December 09, 2018, 05:18:24 PM »
You can only jog on screens where there is a jog On/Off button. That might be the issue?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Motors turn with G code but not with keyboard...Help!
« Reply #2 on: December 09, 2018, 05:22:10 PM »
That was a fast response. THANKS!!

UPDATE....  The DRO's will not move using the keyboard either. (using the arrows and page up and page down)

You can only jog on screens where there is a jog On/Off button. That might be the issue?

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: Motors turn with G code but not with keyboard...Help!
« Reply #3 on: December 09, 2018, 05:39:20 PM »
It certainly sounds like jogging is turned off, or maybe you are in MPG mode?
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Motors turn with G code but not with keyboard...Help!
« Reply #4 on: December 09, 2018, 08:27:46 PM »
UPDATE:    Looks like the MPG flyout is not working right (Press tab key it shows on the screen)

I get a Yellow LED when I press Shuttle Mode

No LED shows at Jog mode.

Where do I turn on Jog Mode?






It certainly sounds like jogging is turned off, or maybe you are in MPG mode?
Re: Motors turn with G code but not with keyboard...Help!
« Reply #5 on: December 11, 2018, 12:56:53 AM »
To answer my own question after doing a bit of research....  Ctrl-Alt-J turns On/OFF Jog Mode.... Heck it is right on the dang Button under tool information duh!
Odd place for it but it is there.


UPDATE:    Looks like the MPG flyout is not working right (Press tab key it shows on the screen)

I get a Yellow LED when I press Shuttle Mode

No LED shows at Jog mode.

Where do I turn on Jog Mode?






It certainly sounds like jogging is turned off, or maybe you are in MPG mode?