Hello Guest it is July 22, 2019, 09:25:19 PM

Author Topic: invisible gremlins  (Read 634 times)

0 Members and 1 Guest are viewing this topic.

invisible gremlins
« on: October 25, 2018, 09:45:52 AM »
Hi everyone,

I'm new to this forum but glad to be here, i have a strange problem that i'm hoping someone can help me with.

I have a 3 axis router, 3m x 1.5m x 350mm gantry type. I have Mach 3 and i have just finished building it and i am soo looking forward to running some code, (its my first build) but therein is my problem, when i "Ref all home" it does exactly what it should, if i "go to zero"... no problem, i can type a line of code on the MDI and it executes without a hitch, but i cant run a gcode without all the axis's going scatty, they make jerky movements big enough to shake the neighbours house.

I chased EMI around for about 3 weeks till i realized its not that, i did have a little trouble with that (emi) but i re routed my spindle cable and it is sorted.

Does anyone have any idea why i cannot run a code through mach3 without this jerking.

I tried some of my own code and i tried the default road runner but i get the same jerky movements, i cant let it run for more than a few seconds, its too rough. My motors are fine, my break out board is ok, my micro stepper controllers are ok, the spindle is ok, it just wont let me run gcode from the computer.

I think it is a mach 3 setting somewhere but i can't find it. Any ideas?

Thanks in advance
Tackleboxman

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
Re: invisible gremlins
« Reply #1 on: October 25, 2018, 10:58:15 AM »
Try turning on CV mode in general config, and see if it helps?

Without seeing the machine run, it's a bit difficult to understand what you are saying.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: invisible gremlins
« Reply #2 on: October 25, 2018, 11:07:13 AM »
Hi ger21,

Thanks for the response, i'm willing to try any suggestions.

I did try that (CV mode) back and forth for a while but it didn't fix the problem, i will make a short video of what its doing in the morning, i'm in South Africa and our work day has just ended.
Re: invisible gremlins
« Reply #3 on: October 26, 2018, 12:08:07 PM »
Hi again,

I managed top take a few videos but they are a little bit too big to post here so here's a link to download them, i think they are both less than 20 megs each. the short video 45s is the machine running under mach 3 control, its not fun to watch, and the 1 minute video is everything running smoothly with me controlling the movements from the keyboard.

I cant imagine that the problem is anything other than mach 3 somewhere, but i don't know where.

https://1drv.ms/f/s!AvolCJeAoVysumTmMTN1RSwiHrk3

I hope there someone in this universe who can help me with this, i am going crazy not being able to run some code after all this time.

Regards

Tackleboxman

Offline ZASto

*
  •  152 152
    • View Profile
Re: invisible gremlins
« Reply #4 on: October 26, 2018, 02:37:08 PM »
You have problem, in my opinion with acceleration. It is way too high.
Post your xml file so that we can discuss further.
Make no mistake between my personality and my attitude.
My personality is who I am.
My attitude depends on who you are.
Re: invisible gremlins
« Reply #5 on: October 27, 2018, 03:05:15 AM »
Hey ZASto, ger21,

here's a link to my xml files, hoping you can find something here.

Thanks again.

https://1drv.ms/f/s!AvolCJeAoVysumVTAkMYBicY5x4u

Tackleboxman

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: invisible gremlins
« Reply #6 on: October 27, 2018, 03:13:47 AM »
Hi Tackleboxman,

It would perhaps be best if you use the Reply Tab then the Additional Options... to post your .xml file to the forum.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: invisible gremlins
« Reply #7 on: October 27, 2018, 03:21:38 AM »
Hi Tweakie.CNC,

I thought my files were too large so i was sharing them via a link, I'll try adding the xml backup here after typing this, the files are about 6.5 megs tho... lemme try and see.  ;)
Re: invisible gremlins
« Reply #8 on: October 27, 2018, 03:38:04 AM »
Please excuse my ignorance, i see now having looked at the xml files there are many "backups" with different dates, i have attached the latest ones and i'm hoping they are correct. one is for the mill setup and the other for the router, which i think is the same setup. (aish i hope i don't sound too stupid here).  ;D

Thanks

Tackleboxman

hmmm, ok it wouldnt let me upload files of that type.... ill try zip them first and see what happens.

Offline Tweakie.CNC

*
  • *
  •  7,849 7,849
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: invisible gremlins
« Reply #9 on: October 27, 2018, 04:04:43 AM »
Hi Tackleboxman,

The zipped files look just fine.

( Sorry but I forgot to mention earlier that the forum only allows files with a unique name to be posted)

Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.