Hello Guest it is May 25, 2019, 01:47:16 PM

Author Topic: Spindle On and Off- Please help  (Read 509 times)

0 Members and 1 Guest are viewing this topic.

Spindle On and Off- Please help
« on: July 24, 2018, 11:29:47 AM »
Good morning, any help on this issue, is greatly appreciated.
Runing Mach3 on 4x8 CNC, steppers and spindle.
I can turn on and off the spindle from Mach 3.
When I load a program, the spindle starts and then when the Gcode start running, the spindle shuts off and right after the program finishes,
the spindle starts back on.
I also see the yellow abnormal condition on, but that refers to the axis...

What I have been doing is that as soon as I see the spindle CW F5 button start flashing , I can click on it again to start the spindle , finish the cut , and then
turning it off...
Thanks

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle On and Off- Please help
« Reply #1 on: July 25, 2018, 01:59:57 AM »
Quote
What I have been doing is that as soon as I see the spindle CW F5 button start flashing , I can click on it again to start the spindle , finish the cut , and then
turning it off...

The spindle should be running when the CW F5 button is flashing - is that the way you have it set-up ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Spindle On and Off- Please help
« Reply #2 on: July 25, 2018, 08:12:03 AM »
Hello, I appreciate your help very much.
Before I press the Cycle Start , the spindle is already running. When I start the program, the Spindle CW F5 is blinking , and the spindle stops. When the program ends, the Spindle CW F5 stops and the spindle starts again.
Let me know what are your thought please
Thanks
Manny

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle On and Off- Please help
« Reply #3 on: July 25, 2018, 09:48:24 AM »
Sounds like you have your spindle control incorrectly wired - the spindle should not be running before Cycle Start is pressed.
You need to check your wiring connections.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Spindle On and Off- Please help
« Reply #4 on: July 25, 2018, 09:56:04 AM »
When the machine is powered on, Mach3 is not up on the screen, the spindle is off. When I open up Mach3 , the spindle comes on and then the sequence I previously described. Does it have to do with the Pins on the BOB? Where to find the pins for the relay...

Offline Tweakie.CNC

*
  • *
  •  7,765 7,765
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Spindle On and Off- Please help
« Reply #5 on: July 25, 2018, 10:06:17 AM »
I don't think this is the answer but try...

In Config / Ports & Pins / Spindle Setup - note the Output# used for Clockwise (M3).
In Config / Ports & Pins / Output Signals – for the Output# noted above, change the Active Low setting.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline TPS

*
  •  1,254 1,254
    • View Profile
Re: Spindle On and Off- Please help
« Reply #6 on: July 26, 2018, 03:08:53 AM »
if you tell us witch BOB you are using, and what is cobbected on the BOB,
someone may be able to help.
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.