Hello Guest it is July 16, 2019, 01:00:39 AM

Author Topic: Mach3 set up for clearpath motors and c62 BOB with Ethernet SmoothStepper  (Read 2073 times)

0 Members and 1 Guest are viewing this topic.

Thanks Craig,
I am going to order the c10 boards and go that route.
Craig, was your yes in your previous post to my latter question about the C34CP board?
Hi,
Quote
Have you read the manual for the C34CP DRIVER CLEARPATH BOARD Rev. 1.
No, I haven't, I didn't know it existed, do you have one?

I think I can reasonably promise that if you had a couple of simple C10s you could get your machine running. No doubt the extra circuitry
of the C62 could be used to advantage but only if you follow the manufacturers/designers solution. As soon as you depart from that scheme
you are in trouble. By all means follow the manufacturer if you wish OR get some C10s and do it yourself.

Craig
My wife left with my best friend...
     and I miss him!
Yes i have a C34CP board for each axis. 

I am pursuing the C10 route but also hoping that what Arturo from CNC4PC told me, which is that clearpath motors have been used with this board before, is true.

Offline ger21

*
  • *
  •  6,288 6,288
    • View Profile
    • The CNC Woodworker
If you want a really good breakout board for the ESS, look at the MB2 from CNC Room.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Hi,
yes they are not bad but they have already assigned inputs and outputs in a particular
fashion...that means OP is back to having to follow one manufacturers design ideas
whether he wants to or not. Neither are they cheap.

Three C10s for under $75.00.....vs $150 for the MB2.

Craig
My wife left with my best friend...
     and I miss him!
Hi,
 just read through the C34CP manual, they solve your problem don't they?

Just cut the RJ45 plug off Clearpath servo cable, solder on to the C34CP then plug
the C34CP into the axis socket on the C62.

Craig
My wife left with my best friend...
     and I miss him!
Yes Craig,
The C34CP board should solve the problem however the only way i can enable the clearpath motors is by switching the jumper on the C34CP board from SOFT enable to HARD enable.  I would prefer to enable the motors through Mach3 but have been unsuccessful so far. 
After several hours of reading the manuals over and over I might have found the problem.  If you could double check me on this Craig that would be much appreciated.  I have attached the necessary documents for your convenience.

On page 41 of the Teknic clearpath manual there is a pin layout for the Teknic control cable.  Pin 1 (green) is HLFB+ and Pin 5 (red) is HLFB-.  According to the wiring example on page 50 of the same manual I need there to be 5-24v (from C62 input terminal) applied to HLFB+ and HLFB- needs to attached to GND on an input terminal of my B.O.B. in order for my motors to enable.

The C34CP adapter manual on page 5 shows the clearpath to RJ45 pin layout.  Clearpath pin 5 (HLFB-) is connected to RJ45 pin 4 (GND).  This connection is correct but when you look at the Clearpath pin 1 (HLFB+) there is no corresponding RJ45 pin applied.  

So it seams the closed required to enable the motors does not exist.  Please let me know if this looks correct.  I also attached the C62 B.O.B. manual to show you the RJ45 pin connection to the B.O.B. layout.  See page 15.

Thank you
Hi,

Quote
applied to HLFB+ and HLFB- needs to attached to GND on an input terminal of my B.O.B. in order for my motors to enable.
No HLFB is the fault signal. There are a few options how you program when the HLFB operates inside the servo but the most useful
one is 'In Position'. So when the servo is in position and correctly following the input commands the signal will be active.
Thus if you have 5-24V on HLFB+ under normal circumstances 5-24V will appear on HLFB-. If however the servo can't keep up
with its commanded input then HLFB- will be 0V.

You will want Mach to monitor this signal and if the servo faults then it will probably Estop. You could use a Brain in Mach3 or you could
attach it to a limit switch so that if the servo faults Mach equates that with a limit switch event and turns off.

To enable your servo attach 5-24V to Enable+ and 0V to Enable-.

Craig
My wife left with my best friend...
     and I miss him!