Hello Guest it is November 22, 2019, 03:10:39 PM

Author Topic: mach 4 plasma  (Read 3345 times)

0 Members and 1 Guest are viewing this topic.

Re: mach 4 plasma
« Reply #20 on: August 01, 2019, 02:13:28 PM »
Hi,
m03 is meant to start the arc, The machine will wait until the arc starts as signaled by the 'Arc OK' signal.
If it doesn't get that signal eventually it will fault 'Timed Out'.

From what you have described the fault is you plasma is not starting.

What sort of plasma machine are you using?

Craig
My wife left with my best friend...
     and I miss him!
Re: mach 4 plasma
« Reply #21 on: August 01, 2019, 02:24:11 PM »
I have a hypertherm powermax 1000 g3, but i just want my machine to do touch off and thats it.....i dont care about the "arc ok" signal...is there a way to opt out of it that im missing in the settings? I have it set to manual mode, for probe i have probe 0 only and "ignore all other probs" checked off.
Re: mach 4 plasma
« Reply #22 on: August 01, 2019, 02:35:18 PM »
Hi,

Quote
but i just want my machine to do touch off and thats it.....i dont care about the "arc ok" signal...is there a way to opt out of it that im missing in the settings?

But you have called m03....ie start the plasma......therefore the machine waits for the ArcOK signal. Its fundamental to the
operation of plasma tables.

If you just want to touch off why don't you use either g31 direct  or write a script that includes a g31?

What you are trying to do is use a very small subset of a module that has many interlocked and dependent procedures,
when you use just one procedure the module expects you to carry on with the others....and faults if you don't.

Craig
« Last Edit: August 01, 2019, 02:44:14 PM by joeaverage »
My wife left with my best friend...
     and I miss him!
Re: mach 4 plasma
« Reply #23 on: August 01, 2019, 03:48:33 PM »
Oh ok thank you for the info....the reason i wasnt worried about it or didnt car is because when i made my interface connection cable from the motion controler box to the hypertherm 1000 i only used 2 wires (shielded)  which i used to turn on the torch but i didnt do anything with the other 2 pins which are the arc ok signals.......do you think i will have an issue once i make a new interface cable with the arc ok wires in it?

I find it weird that i get the same (3 merror_timed_out) in the simulation run......is thtlat normal?

Offline Chaoticone

*
  • *
  •  5,630 5,630
  • Precision Chaos
    • View Profile
Re: mach 4 plasma
« Reply #24 on: August 01, 2019, 03:59:51 PM »
Quote
i dont care about the "arc ok" signal...is there a way to opt out of it that im missing in the settings?

Craig is exactly right. You should really consider more automation or less. You are in a weird manumatic place.

But there is a way. If in the plasma screen configuration you enable "Use Analog Voltage for Arc OK" and make sure your target voltage and actual voltage register is set to a value between the min and max you set up in the plasma screen configuration and set the THC mode to manual it will work.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: mach 4 plasma
« Reply #25 on: August 01, 2019, 04:20:40 PM »
But i only have the torch firing wires in use with a relay on my board, nothing to measure any voltage from my torch or machine..........will i have to make a new interface cable to use the other pins for arc ok in the hypertherm to my break out board then? Should i just make one to be safe?
Re: mach 4 plasma
« Reply #26 on: August 01, 2019, 04:21:39 PM »
Or is there a way to get it to work with just the torch on/ off pins?

I just want it to touch off

Offline Chaoticone

*
  • *
  •  5,630 5,630
  • Precision Chaos
    • View Profile
Re: mach 4 plasma
« Reply #27 on: August 01, 2019, 04:30:54 PM »
Quote
Or is there a way to get it to work with just the torch on/ off pins?

I just told you how to do it.
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!
Re: mach 4 plasma
« Reply #28 on: August 01, 2019, 05:04:20 PM »
Here is mine settings. Does works for me. Touch off (+ Pierce delay / high ..) only. No THC
« Last Edit: August 01, 2019, 05:09:28 PM by cncNor »
Re: mach 4 plasma
« Reply #29 on: August 01, 2019, 05:20:51 PM »
Oooh duuuh haha i just wasnt sure if you understood my home made interface connection only has 2 wires lol ....im gonna give it a try today 😁