Hello Guest it is September 19, 2019, 11:58:49 AM

Author Topic: Scripter Compile Error bites again :(  (Read 5062 times)

0 Members and 1 Guest are viewing this topic.

Re: Scripter Compile Error bites again :(
« Reply #10 on: February 19, 2018, 02:39:03 PM »
Hi Dave,
one of the arguments in favour of Mach4 is that Lua is stable.

Craig
My wife left with my best friend...
     and I miss him!

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Scripter Compile Error bites again :(
« Reply #11 on: February 19, 2018, 02:46:40 PM »
Hmmm.....
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline rcaffin

*
  •  1,003 1,003
    • View Profile
Re: Scripter Compile Error bites again :(
« Reply #12 on: February 27, 2018, 04:38:30 AM »
Thomas's suggestion 'feels' right.
Try putting 'end <LF> at the end (ie a comment).

Cheers
Roger

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Scripter Compile Error bites again :(
« Reply #13 on: February 27, 2018, 10:07:39 AM »
I deleted the file, made a new one with a couple of returns after the code.

Not had the issue again yet.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Scripter Compile Error bites again :(
« Reply #14 on: March 12, 2018, 02:47:10 PM »
And.....It's back :(

Ran all day yesterday, not a hint of trouble. Tonight I had one quick job and this time I get no tool length compensation.

The error message this time was "scripter compile error in M6End.m1s" - this is why no TLC as that is in my M6End macro.

Now, last time the M3.m1s played up I saved it as M3.mcc which i believe is pre-compiled?

Seems odd that it now failed on the M6 macro - I have now saved both M6Start & M6End as .mcc files - in the vain hope that it will stop it doing it again. Of course there will always be another macro to fail I guess. :(
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline TPS

*
  •  1,388 1,388
    • View Profile
Re: Scripter Compile Error bites again :(
« Reply #15 on: March 12, 2018, 03:41:34 PM »
witch Version of Mach3 are you running?
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Scripter Compile Error bites again :(
« Reply #16 on: March 12, 2018, 03:45:41 PM »
V062
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline TPS

*
  •  1,388 1,388
    • View Profile
Re: Scripter Compile Error bites again :(
« Reply #17 on: March 12, 2018, 03:49:11 PM »
ok i turn the "i know something better" mode ON again,

v022 and i am happy with it

"i know something better" mode OFF
anything is possible, just try it.
if you find some mistakes, in my bad bavarian english,they are yours.

Offline Davek0974

*
  •  2,577 2,577
    • View Profile
    • DD Metal Products Ltd
Re: Scripter Compile Error bites again :(
« Reply #18 on: March 12, 2018, 03:57:22 PM »
Yes it has been mentioned before, trouble is, i can't find out what, if any, things may stop working or not work how I expect when downgrading - this i s a fairly customised setup I think and I don't want to risk buggering something up ;)

Also, where do i find the old version?
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline rcaffin

*
  •  1,003 1,003
    • View Profile
Re: Scripter Compile Error bites again :(
« Reply #19 on: March 12, 2018, 04:39:34 PM »
Quote
The error message this time was "scripter compile error in M6End.m1s" - this is why no TLC as that is in my M6End macro.

You do know that if you bring up the Operator/VB Script Editor you can run the M6End macro from there, and it will (normally) stop at the problem line?

Cheers
Roger