Author Topic: Homing Z-Axis during G-Code process  (Read 2657 times)

0 Members and 1 Guest are viewing this topic.

Offline Csaba911

  • Active Member
  • Posts: 27
    • View Profile
Homing Z-Axis during G-Code process
« on: July 02, 2007, 05:33:05 AM »
Hi I am New to the group and this is my first question. I have a converted Proxxon MF70 . All homing and Soft Limits are properly set up. Everything works my question is more this: When I am trying to Home in the middle of the G-Code processing the Z-Axis won't pull up   :o to 0 first leading to scratch the piece I was working on. Is there somewhere a way to tell it that when "Homing" is pressed the fist thing would be Zeroing the Z-Axis ?  ???

 

Offline Chaoticone

  • Administrator
  • *
  • Posts: 5,461
  • Precision Chaos
    • View Profile
Re: Homing Z-Axis during G-Code process
« Reply #1 on: July 02, 2007, 08:00:40 AM »
Hey Csaba,
    Are you doing this with the ref. all home button? If so, you can go in the button and edit the vb script. Also, you might want to look at configuring your safe Z.

Brett
;D If you could see the things I have in my head, you would be laughing too. ;D

My guard dog is not what you need to worry about!

Offline zealous

  • Active Member
  • Posts: 492
  • HI!
    • View Profile
    • Artsoft Solutions
Re: Homing Z-Axis during G-Code process
« Reply #2 on: July 02, 2007, 02:36:39 PM »
I belive in Mach 2 I had this problem with "Home" button where it would move all the axis at once, so the Z would scrap my part while the X and Y moved.
You can fix this by editing the button

Just what Brett said:

-Go to "operator"
-"Edit button Script"
-and press on the button

for "Ref All Home", this will move X, than Y, than Z, than A, and will wait for them to hit home before doing the next axis:

Add this if it's not there:

DoButton( 24 )
DoButton( 23 )
DoButton( 22 )
DoButton( 25 )

Also as Brett said:

check if you're Z Safty is on:

-"Config"
-"safe Z setup"
-Safe Z and Optional "Goto safe Z when Stop Button is hit"

Offline Csaba911

  • Active Member
  • Posts: 27
    • View Profile
Re: Homing Z-Axis during G-Code process
« Reply #3 on: July 02, 2007, 05:04:39 PM »
Thanks guys ! Now it's behaving very bravely. This group is very nice thanks again. It was just a little button that I didn't know what it was for. But I'm getting the hang of it slow and easy. The Safe -Z was not enabled. But now it works like a charm. Great Product, great Support I'm glad I 've chosen this product.

 :)