Hello Guest it is April 19, 2019, 04:56:56 AM

Author Topic: Help with Lua error "Invalid value 2 for a boolean key "WholeWord" in config fi  (Read 886 times)

0 Members and 1 Guest are viewing this topic.

"Invalid value 2 for a boolean key "WholeWord" in config file"

I'm struggling to program m6 for my ATC.

I thought I had it licked, just needed to change all of my mc.mcCntlGcodeExecuteWait to mc.mcCntlGcodeExecute, but I've made too many changes and broken something.

Any clue for the meaning of this error message is greatly appreciated.

Leo
Hi,
I've got exactly the same problem. I was shagging around writing some code and I think as a result of a misclick I introduced a dodgy number
as a Boolean into the .ini file. I haven't found it yet but it doesn't seem to have broken anything else.

Craig
My wife left with my best friend...
     and I miss him!
Hi,
I've searched the .ini file for 'WholeWord' and various other names but not found anything related to the error.

I'm now thinking that the configuration file referred to in the error message is not the profile .ini file but may be something to do with
McLuaEditor or something.

Craig
My wife left with my best friend...
     and I miss him!
I think it could be a bug in the Lua editor.

The last thing I remember doing before the error appeared involved using a lot of Find & Replace where match WholeWord was set to ON. 

Now I've set match WholeWord to Off and the error seems to have gone.
Hi Durero,
I did as you suggested and the warning has disappeared....you beaut.....

Thanks again.

Craig
My wife left with my best friend...
     and I miss him!