Hello Guest it is June 17, 2019, 11:30:54 AM

Author Topic: Tool setting changes Mach3 Turn  (Read 841 times)

0 Members and 1 Guest are viewing this topic.

Tool setting changes Mach3 Turn
« on: October 04, 2017, 02:19:43 PM »
Hi
I have an issue. My cnc lathe has an 8 tool ACT. The tool table is set with tool no 1 as the master.
Normally every thing works perfect when canging tools but; i run the Mach 3 wizzard, save, post the code and run the code. Evrything is ok. Than I go back and do som changes in the wizzard , save, post code and than the tool setting is completly wrong. No toolchange has been done. Same tool in the DRO as well.
Than I restart the PC, set master tool and every thing is ok again.



Sent from my iPad using Tapatalk
Re: Tool setting changes Mach3 Turn
« Reply #1 on: October 07, 2017, 02:18:17 AM »
Still having the problem. I run an old PC may be this is the problem?
Processor is 2387 Mhz
Total Physical Memory 1 024,00 MB
Available Physical Memory 453,42 MB after the tool setting changed.
Tool setting goes lik X +14 to -28 Z from 0 to +88 meaning crash if the emergency button is far away.
I have two parallell ports in the PC, LPT2 is used only for the two MPG wheels.

Any suggestions?
Re: Tool setting changes Mach3 Turn
« Reply #2 on: October 07, 2017, 04:54:10 AM »
I had the task manager up when running a taper program and CPU and memory was hardly in use. Something else must be wrong.
Funny thing. Axis position suddenly changes from X +23 to -18.5 Z 0 to +42,73