Hello Guest it is October 15, 2021, 11:43:01 PM

Author Topic: All the Gear and No Idea (as to why nothing happens)  (Read 6225 times)

0 Members and 1 Guest are viewing this topic.

All the Gear and No Idea (as to why nothing happens)
« on: September 03, 2017, 07:18:51 AM »
OK , the problem is nothing is happening when I try anything, absolutely no communication with the engraver/router.
OS, windows 7 with absolutely NO other programs in the computer.
Mach3 and Planet CNC USB ?? are the only programs and the Planet one was only installed after I found that Mach3 wasn't communicating with the engraver/router.
I had installed the DEMO version of Mach3 in my MacPro and tried to run it using Parallels Desktop, but no joy. So I bought a recon PC with a fresh copy of Windows 7 installed. Installed my REGISTERED copy of Mach 3 and applied the licence. (My name comes where it's supposed to be)
The Engraver/router is the Chinese 3020T  4 axis   (VEVOR Tack Hooks).
Using the USB or Parallel ports make no difference, there is no jog function or movement when I load a demo file. The File runs on the computer but that's all that happens.
What do I do please ?
« Last Edit: September 03, 2017, 07:25:49 AM by basilhenriques »
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #1 on: September 03, 2017, 07:20:25 AM »
More info. SEE MIDDLE PICTURE.. When powered up these lights come on in the controller:-
« Last Edit: September 03, 2017, 07:31:57 AM by basilhenriques »
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #2 on: September 03, 2017, 07:21:35 AM »
Final info.
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #3 on: September 03, 2017, 07:39:09 AM »
Hi,
welcome aboard.

The very first picture you posted shows a parallel printer port and a USB port. I suspect the USB port is just a means for your PC to power the input
circuits of your breakout board but the signals are communicated over the parallel port. Do you have a DB25 cable?

Given that your machine requires a parallel port to communicate have installed the parallel port driver? Have you run DriverTest.exe to see
whether its running OK?

You may need to go to the Artsoft website an get a copy
Quote
Mach3 CNC Controller
Software Installation and
Configuration

You need to read section 2.1.3    and then read it again   and again!
Quote
2.1.3 The Vital Reboot
You must reboot Windows before running Mach3. This reboot is vital. If you do not do it, you will get
into great difficulties which can only be overcome by using the Windows Control Panel to uninstall the
driver manually. So please reboot now.

Craig
My wife left with my best friend...
     and I miss him!
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #4 on: September 03, 2017, 08:21:17 AM »
Thanks for the reply, I have used each port singly and together.. I said
OK , the problem is nothing is happening when I try anything, absolutely no communication with the engraver/router.
OS, windows 7 with absolutely NO other programs in the computer.

Using the USB or Parallel ports make no difference, there is no jog function or movement when I load a demo file. The File runs on the computer but that's all that happens.
What do I do please ?

Offline Tweakie.CNC

*
  • *
  •  8,828 8,828
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #5 on: September 03, 2017, 10:21:47 AM »
If you attach your <profile>.xml file (the one from your Mach3 folder) we can at least check the settings you are using for Parallel Port operation. Copy and rename the file to Basil.xml before attaching.

Tweakie.
KEEP SAFE !
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #6 on: September 03, 2017, 01:05:46 PM »
Thanks 'Tweakie' unfortunately I am not au fait with Windows and PCs, I have always used Macs. So, I don't know how to do a screenshot in windows; so I've copied the Mac3 folder onto a portable dive (just for this purpose of doing a screenshot of the contents) and on the mac I CAN take a screenshot. There is no file <profile.xml> file but there is a file 'profile' that's a text file and it contains just the text :- Mach3Mill.
I appreciate your help..
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #7 on: September 03, 2017, 01:13:51 PM »
I purchased the licence from Amadeal http://www.amadeal.co.uk/acatalog/Mach-3-Licence-.html but received no manual, I followed the instructions that the program gave when it was installing..
Clean install On a new refurbished Dell on a freshly installed version of Windows 7, with absolutely no other programs or games installed Just Mach3, and when it wouldn't work I downloaded "Planet CNC USB" but that didn't work either. Everything is less than a week old..Except the engraver/router, that's a few weeks old..


EDIT; Attachment containing personal details deleted for security reasons.
« Last Edit: September 05, 2017, 01:52:30 AM by Tweakie.CNC »
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #8 on: September 03, 2017, 01:32:57 PM »
I got this system just to engrave 16 and 19mm copper discs with my company logo, and also to machine some small aluminium parts for my reproduction Van Eps Dampers.
Re: All the Gear and No Idea (as to why nothing happens)
« Reply #9 on: September 03, 2017, 02:28:18 PM »
Hi,
now you have to get it to work....

Run DriverTest.exe from the Mach3 folder an report the results or better still post a screenshot. This tests the parallel port on your PC, you don't even
need the machine hooked up, in fact probably better not to.

Craig
My wife left with my best friend...
     and I miss him!