Hello Guest it is October 17, 2019, 07:42:27 PM

Author Topic: CNC plasma wont cut in a straight line  (Read 1651 times)

0 Members and 1 Guest are viewing this topic.

CNC plasma wont cut in a straight line
« on: August 01, 2017, 01:46:52 PM »
So I have been racking my brain trying to read everything possible to get this plasma table setup and to run correctly. I am definitely getting more gray hair by the day. eagle plasma4x8,hypertherm powermax 65, proma thc
When Im trying to cut ANYTHING its always wavey and Im not sure if its something in the software thats not setup right or what. going broke buying metal to keep practicing on. Also trying to get this THC controller to work correctly. when I ran in last it went up and kept going up til it was done running. I have attached a couple photos of me trying to cut straight lines trying to get the THC setup correctly. I have team viewer if someone wanted to look at how everything is setup.
Re: CNC plasma wont cut in a straight line
« Reply #1 on: November 30, 2017, 09:44:10 AM »
I have the same exact setup... I am in midst of starting it up tonight so any learned guidance would be appreciated, what did you figure out?
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.
Re: CNC plasma wont cut in a straight line
« Reply #2 on: November 30, 2017, 11:03:28 PM »
If you connect a marker pen to the torch head, turn the plasma machine off, run the program, does the machine draw a straight line ?
Re: CNC plasma wont cut in a straight line
« Reply #3 on: December 01, 2017, 07:25:02 AM »
Yes, It  draws straight lines. I think maybe mechfx must not have his table and or carriage square. It looks like its "crab-walking". http://www.youtube.com/watch?v=r_VDDNEgah8
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.
Re: CNC plasma wont cut in a straight line
« Reply #4 on: December 01, 2017, 07:42:39 AM »
At a guess , If it is drawing a straight line without the plasma being on, and wobbly lines when it is, then I'd say that there is a significant electrical interference occurring.

I'd be checking the earth connections, making sure the motor cables are not running parallel to the Plasma torch line or earth lead anywhere.

Is there shielding in the motor cables ?

I'd also try again without the THC switched on. Try and isolate/eliminate one thing at a time.

Note : The proma THC instructions make a point of making sure the earth of the THC board is NOT shared with its power supply earth, it must be common with the computer/table earth.

trying to help,
cheers
Art
Re: CNC plasma wont cut in a straight line
« Reply #5 on: December 18, 2017, 08:38:14 AM »
So here is my dilemma, this is what I get when trying to cut (see pics) what I thought was EMI noise obviously is not because it does the same with a sharpie. I have tried stock dxf files as well as stock tap files and its the same. Anyone have any ideas? I attached a pdf of the dxf of what the "sharpie cut" pic is suppose to look like. It loads into Mach3 correctly, just does not cut correctly. I calibrated the X-Y & Z axis through the "Set Steps Per Unit" function as well. Appreciate any and all help!
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.
Re: CNC plasma wont cut in a straight line
« Reply #6 on: December 18, 2017, 09:01:47 AM »
So here is my dilemma, this is what I get when trying to cut (see pics) what I thought was EMI noise obviously is not because it does the same with a sharpie. I have tried stock dxf files as well as stock tap files and its the same. Anyone have any ideas? I attached a pdf of the dxf of what the "sharpie cut" pic is suppose to look like. It loads into Mach3 correctly, just does not cut correctly. I calibrated the X-Y & Z axis through the "Set Steps Per Unit" function as well. Using UC100 USB connection. Appreciate any and all help!
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.
Re: CNC plasma wont cut in a straight line
« Reply #7 on: December 18, 2017, 10:46:06 PM »
Hi,
what is the Steps per Unit value? Could it be that you have insufficent resolution to cut an interpolated line?

Craig
My wife left with my best friend...
     and I miss him!
Re: CNC plasma wont cut in a straight line
« Reply #8 on: December 19, 2017, 07:14:12 AM »
Thanks for responding Joe,
One factor I neglected to state was that I am using a XYZ-USB UC100 controller.

The steps per unit are as follows;

X- 533
Y- 533
Z- 2000

When calibrating through the "Steps per unit function" measurement wise it is spot on.
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.
Possible USB controller issue?
« Reply #9 on: December 19, 2017, 07:21:38 AM »
So here is my dilemma, this is what I get when trying to cut (see pics) what I thought was EMI noise obviously is not because it does the same with a sharpie. I have tried stock dxf files as well as stock tap files and its the same. Anyone have any ideas? I attached a pdf of the dxf of what the "sharpie cut" pic is suppose to look like. It loads into Mach3 correctly, just does not cut correctly. I calibrated the X-Y & Z axis through the "Set Steps Per Unit" function as well. after calibration I check it over 7' and 4' and it is spot on.  I am using a XYZ USB UC-100 Controller. Windows 7 64 bit. Your help is appreciated!
Appreciate any and all help!
Eagle Plasma 4' 8', THC, Floating Head, Powermax 65 W/ machine torch, IR 7.5HP  80gal.  24 CFM 2 Stage compressor. Windows 7 64bit, XYZ USB UC-100 Controller.