Hello Guest it is May 23, 2019, 05:52:06 AM

Author Topic: Module Works Simulator  (Read 8661 times)

0 Members and 1 Guest are viewing this topic.

Offline Mauri

*
  •  292 292
    • View Profile
Re: Module Works Simulator
« Reply #20 on: May 31, 2017, 06:29:29 PM »
Beerbatter,
I see your problem.
You are missing the ModuleWorks in Mach4 Plugins.
See my Screen capture below.
Regards,
Mauri.

Offline Mauri

*
  •  292 292
    • View Profile
Re: Module Works Simulator
« Reply #21 on: May 31, 2017, 06:31:24 PM »
Chaoticone,
Why do we not have V3390 for ModuleWorks plug in as V3390 Mach4 is the latest Production release.
Regards,
Mauri.

Offline smurph

*
  • *
  •  1,085 1,085
  • "That there... that's an RV."
    • View Profile
Re: Module Works Simulator
« Reply #22 on: May 31, 2017, 06:52:15 PM »
Plugins don't have to be at the same build level.  All of the Mach supplied plugins (in the installer) are the same level because they get built at the same time as the Core and GUI.  So a plugin from a different developer can be different.  Some developers may choose to put the Mach build level at which they compiled against (looks to be what ModuleWorks has done).  Unless the Mach API changes, there isn't a need to make a new plugin build other than fixing things or adding functionality.   

Steve
Re: Module Works Simulator
« Reply #23 on: May 31, 2017, 07:27:30 PM »
OK.  So how do I get the Simulator-ModuleWorks plugin to show up in the Mach configuration window?
Thanks

Offline Mauri

*
  •  292 292
    • View Profile
Re: Module Works Simulator
« Reply #24 on: May 31, 2017, 07:56:39 PM »
Beerbatter,
Life was not meant to be easy.
Below I have all the MW plugins installed and what shows up in Mach4.
Then with MW plugin related to the Mach4 Plugin windows under config it shows it missing.
If you have these two files missing then it will not load the MW plugin into Mach4.
Hope this helps.
Regards,
Mauri.
Re: Module Works Simulator
« Reply #25 on: May 31, 2017, 08:09:18 PM »
Below is everything that is in the Plugins sub-directory after a fresh install of Mach4 and MW.
Can someone please send me the missing files?
Thanks

Offline Mauri

*
  •  292 292
    • View Profile
Re: Module Works Simulator
« Reply #26 on: May 31, 2017, 09:00:20 PM »
Beerbatter,
All Looks good to me.
I would have hoped Mach4 Personnel would have responded to this by now.
I am not sure if Mach4 support will answer, but give it a try.
Regards,
Mauri.

Offline smurph

*
  • *
  •  1,085 1,085
  • "That there... that's an RV."
    • View Profile
Re: Module Works Simulator
« Reply #27 on: June 01, 2017, 01:57:08 AM »
Mach personnel didn't write the plugin.  ModuleWorks did.  All we can do is load it up and test it.  Just like you.  And it works fine for me, so I don't know what the problem is.  :(

Steve
Re: Module Works Simulator
« Reply #28 on: June 01, 2017, 08:04:40 AM »
smurph,

Interesting that yours works.  A couple of questions.
  Do you have the Hicon files in your Plugins directory?
  Did you receive two separate licenses for Mach4 and MW, or did you receive just one combined license file?

Offline smurph

*
  • *
  •  1,085 1,085
  • "That there... that's an RV."
    • View Profile
Re: Module Works Simulator
« Reply #29 on: June 01, 2017, 01:28:45 PM »
No HiCON files. 

Two separate licenses.