Hello Guest it is January 26, 2020, 09:08:53 PM

Author Topic: Spindle Doesn't Start When Starting Mid Program  (Read 828 times)

0 Members and 1 Guest are viewing this topic.

Offline dq828

*
  •  61 61
    • View Profile
Spindle Doesn't Start When Starting Mid Program
« on: May 27, 2017, 01:56:45 AM »
Hi

I am having issues with the comms to the PMDX board which looses connection during a run. When I try and restart the cutting mid program, while following the instruction manual (I think :)),  the spindle doesn't start but rest seems to work. It's like it's not cycling thru ├índ picking up the fact it needs to start the spindle before proceeding with the cut.

Does anyone know what mistake I'm making. I have tried several times with the same result.

Offline mark4

*
  •  156 156
    • View Profile
Re: Spindle Doesn't Start When Starting Mid Program
« Reply #1 on: May 29, 2017, 10:05:28 PM »
hi first let me say i could be all wet this is out of my comfort zone but you are starting mid program or mid g code where is your m3 or m4 command if it is at the beginning and you are starting in the middle mach never gets the command. as a work around you can manually start the spindle the cycle start your program. hope this helps
m

Offline dq828

*
  •  61 61
    • View Profile
Re: Spindle Doesn't Start When Starting Mid Program
« Reply #2 on: May 30, 2017, 05:21:27 AM »
The way I read the Manual it seems to me when you follow the process they lay out the programme should take that into account, so I figured I was doing something wrong. But yes I could put in a bit of code at the right point and start the spindle myself. I'm shiny new when it comms to running a CNC so the less coding the better, at least for the moment. :)

Thanks for your thoughts.

Offline Stuart

*
  •  204 204
    • View Profile
Re: Spindle Doesn't Start When Starting Mid Program
« Reply #3 on: May 30, 2017, 05:33:18 AM »
a quick and dirty method
if you are certain the tool is in the clear just click on the CW/CCW button on the right hand side of the screen under the green spindle on

Offline dq828

*
  •  61 61
    • View Profile
Re: Spindle Doesn't Start When Starting Mid Program
« Reply #4 on: May 30, 2017, 05:53:07 AM »
Thanks, I'll have a look at that.