Hello Guest it is August 24, 2019, 08:12:04 AM

Author Topic: Change from parallel to ESS SmoothStepper  (Read 2453 times)

0 Members and 1 Guest are viewing this topic.

Change from parallel to ESS SmoothStepper
« on: May 05, 2017, 04:26:35 AM »
Hi,

At the moment im in the process of changing from parallel to ESS "SmoothStepper", to do this it is recommended  that one "downgrades" from Mach3 version 3.043.066 to Mach3 Version 3.043.062, my question is, will the Mach3Mill.xml from version 3.043.066 work in Mach3 Version 3.043.062?

Thanks in advance for your help.
Steve

Online Tweakie.CNC

*
  • *
  •  7,886 7,886
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Change from parallel to ESS SmoothStepper
« Reply #1 on: May 05, 2017, 04:45:47 AM »
Hi Steve,

Its not downgrading it's changing to a version that is known to work well with the ESS.

Yes, you existing .xml file will work just fine.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Change from parallel to ESS SmoothStepper
« Reply #2 on: May 05, 2017, 09:57:51 AM »
Hello Tweakie,

Thank you for your fast answer.

Steve
Re: Change from parallel to ESS SmoothStepper
« Reply #3 on: May 06, 2017, 03:10:47 AM »
Hi,

After changing from parallel to ESS, ESS is connected and running, two motors don't react and one (Y) only moves in one direction?

Thanks in advance for your help.
Steve

Online Tweakie.CNC

*
  • *
  •  7,886 7,886
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Change from parallel to ESS SmoothStepper
« Reply #4 on: May 06, 2017, 03:36:38 AM »
Hi Steve,

First thing to do is perhaps check that you have the ESS port 1 connected correctly (pin for pin) to your BoB.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Change from parallel to ESS SmoothStepper
« Reply #5 on: May 07, 2017, 02:55:00 AM »
Hi,

got that sorted out, thanks for the help.
now the display shows the workpiece being milled correctly but on the table the mill does the work "turned" 45° to the left. where can i correct this?


Steve

Online Tweakie.CNC

*
  • *
  •  7,886 7,886
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Change from parallel to ESS SmoothStepper
« Reply #6 on: May 07, 2017, 03:14:34 AM »
90° I can understand but 45° is bit of a mystery.

Does your Gcode file contain a G68 command ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Change from parallel to ESS SmoothStepper
« Reply #7 on: May 07, 2017, 03:25:53 AM »
Hi,

No G68 in the G code.
i just tried swapping motor output settings the  x & Y step pin & dir pin, this makes the mill do a 90° turn.

Steve

Online Tweakie.CNC

*
  • *
  •  7,886 7,886
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Change from parallel to ESS SmoothStepper
« Reply #8 on: May 07, 2017, 03:32:23 AM »
Hi Steve,

Try adding G69 at the beginning of your Gcode file.

Does this correct the 45° rotation issue ?

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.
Re: Change from parallel to ESS SmoothStepper
« Reply #9 on: May 07, 2017, 03:42:17 AM »
Hi Tweakie,

set the pins back to "45°" setting then added added G69 to the G21 G90 G91.1 G64 G40 line in the gcode, no correction to be seen?

Steve