Hello Guest it is December 01, 2020, 06:11:37 AM

Author Topic: Matsuura MC500V retrofit Help!  (Read 2851 times)

0 Members and 1 Guest are viewing this topic.

Matsuura MC500V retrofit Help!
« on: April 30, 2017, 11:48:17 AM »

So i Have started with a retrofit of a Matsuura MC500V, when i got it i was able to get the drivers running (servodrives and spindle drive) but the controller did not work, so i thougt it would be perfect for a retrofit, i chose to go with the csmip/ip-a  as it seems to be a nice option.
I have started to wire up everything bur i have two problems.

1. Spindle- I have a servo spindle drive (Yaskawa CPCR-QR-CB8D) with +/- 10v control for speed and direction, i am using one of the analog outputs to control the spindle (open loop) and i can get it to start at very low speed, but it sounds twitchy and i cant control the speed. If i check the output for cslabs plug in i can see that the voltage output changes when i change speed , but when i try to measure it with a voltmeter i dont get a reading. I suspect that i have some setting in mach3 wrong. Any ideas? (if i connect a 1.5v battery on the input it runs fine).

2. This is the main problem, i cant get my servo drives to enable. I have the CPCR-MR052 GC drives with two 20 pin connectors, i have read Fly-scales (http://www.machsupport.com/forum/index.php/topic,26470.0.html) and johnfriedls conversion threads, but it does not help me. I think there is some information missing in fly-scales connection drawing regarding how to enable the drives unfortunately he does not reply to email. So if anyone know which one of the connectors in doc 49 is the enable signal and what i need to do (ground it or connect +24v to it) to get it to enable it would be much appreciated.  I feel like i have tried everything.

Any help or thoughts are very welcome!

/ David

Re: Matsuura MC500V retrofit Help!
« Reply #1 on: May 06, 2017, 02:44:21 PM »
i solved these problems.
the spindle problem was simply a connection error when i fixed that it worked great with the +/- 10v option in the cs-labs plugin.

Turns out that the problem with the servo drives was that i needed to use the ground (or - lead ) from the same connector that was used to supply the +24v to the drive, so even if i could measure 24v between the leads and the machine common ground, nothing happened when i used it to ground the enable cables(the ones that goes from the servodrive to the relays in fly-scales scheme).

So many thanks to FLy-scale for the drawing diagram, it was a great help.