Hello Guest it is November 14, 2019, 11:22:13 AM

Author Topic: Mach 4 won't run constant Estop - HELP - Log File Included  (Read 1024 times)

0 Members and 1 Guest are viewing this topic.

Mach 4 won't run constant Estop - HELP - Log File Included
« on: February 20, 2017, 03:52:45 AM »
I haven't even got my lathe up and running; i'm just getting it setup. I'd get random estops occasionally, now it trips instantly. I've attached the log file. I think maybe my CNC4PC M16 BOB is bad or my Pokeys 57E? Seems like it's getting an estop trigger from the motion controller; or as it looks to me from looking at the log file.

Any help would be appreciated.

2017-02-20 00:27:27.147 - [PoKeys] Switching to RUNNING state...
2017-02-20 00:27:27.147 - Signal id 1018, (Enable #0), changed from HIGH to LOW.
2017-02-20 00:27:27.147 - Signal id 1020, (Enable #2), changed from HIGH to LOW.
2017-02-20 00:27:27.147 - Signal id 1120, (Machine Enabled), changed from HIGH to LOW.
2017-02-20 00:27:27.162 - [PoKeys] PoKeys Pulse engine disabled
2017-02-20 00:27:27.162 - [PoKeys] Disabling motion - Buffer with 15 moves is being cleared!
2017-02-20 00:27:27.162 - [PoKeys] Axis enabled changed 0

2017-02-20 00:27:27.178 - [PoKeys] Updating enable output signals
2017-02-20 00:28:02.699 - API: mcCntlEnable(true) called.
2017-02-20 00:28:02.699 - Signal id 1018, (Enable #0), changed from LOW to HIGH.
2017-02-20 00:28:02.699 - Signal id 1020, (Enable #2), changed from LOW to HIGH.
2017-02-20 00:28:02.699 - Signal id 1120, (Machine Enabled), changed from LOW to HIGH.
2017-02-20 00:28:02.699 - [PoKeys] Axis enabled changed 5

2017-02-20 00:28:02.699 - [PoKeys] Updating enable output signals
2017-02-20 00:28:02.715 - [PoKeys] PoKeys Pulse engine enabled
2017-02-20 00:28:02.715 - [PoKeys] Enabling motion - Buffer with 0 moves is being cleared!
2017-02-20 00:28:02.715 - [PoKeys] Updating motion parameters in device
2017-02-20 00:28:02.715 - All motors marked as still.
2017-02-20 00:28:02.715 - All motors marked as still.
2017-02-20 00:28:02.715 - All motors marked as still.
2017-02-20 00:28:02.715 - All motors marked as still.
2017-02-20 00:28:02.715 - API: mcMotionSync() called.
2017-02-20 00:28:02.715 - SyncPosition()! Clearing planner.
2017-02-20 00:28:02.715 - [PoKeys] Switching to RUNNING state...
2017-02-20 00:28:04.727 - API: mcCntlEStop() called.
2017-02-20 00:28:04.727 - API: mcCntlEnable(false) called.
2017-02-20 00:28:04.727 - API: mcMotionClearPlanner() called.
2017-02-20 00:28:04.727 - API: mcAxisDerefAll()
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 0
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 1
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 2
2017-02-20 00:28:04.727 - Signal id 1018, (Enable #0), changed from HIGH to LOW.
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 3
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 4
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 5
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 6
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 7
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 8
2017-02-20 00:28:04.727 - Signal id 1020, (Enable #2), changed from HIGH to LOW.
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 9
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 10
2017-02-20 00:28:04.727 - API: mcAxisDeref() called. axis 11
2017-02-20 00:28:04.727 - API: mcCntlMachineStateClear() called.
2017-02-20 00:28:04.727 - [PoKeys] E-stop due to emergency
2017-02-20 00:28:04.727 - [PoKeys] Switching to RUNNING state...
2017-02-20 00:28:04.727 - Signal id 1120, (Machine Enabled), changed from HIGH to LOW.
2017-02-20 00:28:04.743 - [PoKeys] PoKeys Pulse engine disabled
2017-02-20 00:28:04.743 - [PoKeys] Disabling motion - Buffer with 12 moves is being cleared!
2017-02-20 00:28:04.743 - [PoKeys] Axis enabled changed 0

2017-02-20 00:28:04.758 - [PoKeys] Updating enable output signals
2017-02-20 00:28:13.978 - Signal id 164, (E-Stop), changed from LOW to HIGH.
2017-02-20 00:28:13.978 - API: mcCntlEStop() called.
2017-02-20 00:28:13.978 - API: mcCntlEnable(false) called.
2017-02-20 00:28:13.978 - Signal id 164, (E-Stop), changed from HIGH to LOW.
2017-02-20 00:28:13.978 - [PoKeys] PoKeys Pulse engine disabled

Offline mark4

*
  •  147 147
    • View Profile
Re: Mach 4 won't run constant Estop - HELP - Log File Included
« Reply #1 on: February 25, 2017, 12:12:39 AM »
hello
i recomend you start with how does pokeys or your breakout board recieve estop look at that input check the wire to the switch pull the wire out of its connection and test the wire to ground or short. activate the switch check with meter see what happens ie does the wire change state when the estop is pushed. also what kind of estop does the switch report back to a relay then the relay informs mach or does it have a straight connection to the breakout board.if i were getting random estops the first thing i would check in great detail is the estop circuit. pay attention to the estop switch i had one that would stick finally replaced it. start there if that makes any sence if not post more detail about your estop circuit. is the wire shielded you can also add a capacitor .1 uf across the input terminals to debounce the switch. good luck
mark
Re: Mach 4 won't run constant Estop - HELP - Log File Included
« Reply #2 on: February 25, 2017, 01:50:51 PM »
I've tried that. Switched out to a different switch and wires all together. I think I had a bad board and have since returned it and bought the stand alone pokeys57CNC.