Hello Guest it is May 27, 2019, 05:45:37 AM

Author Topic: Axis dros off after loading Gcode  (Read 986 times)

0 Members and 1 Guest are viewing this topic.

Axis dros off after loading Gcode
« on: December 22, 2016, 08:57:24 AM »
 Hi here is what is going on. I had to reinstall my OS(XP). I reinstalled Mach3 version 3.043.062. Setup everything. Loaded a gcode file and I noticed my z axis Dro was off. I verified this by measuring the movement and comparing it to the dro reading. I moved ~ 1 inch(measured) and the dro reading was .045. I checked the settings in mortor tuning and everything was correct. I closed the file and restarted Mach3. I retested and measured and it was spot on. I reloaded the Gcode file and it was off my a mile. anyone have any idea what could cause this?

Thanks
Charlie
Regards
Charlie M.

Offline Tweakie.CNC

*
  • *
  •  7,766 7,766
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Axis dros off after loading Gcode
« Reply #1 on: December 22, 2016, 10:31:44 AM »
Check your Gcode file.

Just as an example it could be scaling the Z axis or perhaps changing the coordinate system, offsets, etc.

Tweakie.
Success consists of going from failure to failure without loss of enthusiasm.  Winston Churchill.

Offline ger21

*
  • *
  •  6,234 6,234
    • View Profile
    • The CNC Woodworker
Re: Axis dros off after loading Gcode
« Reply #2 on: December 22, 2016, 10:47:44 AM »
Make sure your Native Units match the units you set up your machine to.
This can happen when Native Units is set to mm's, but you setup your machine with inch parameters.
Mach3 defaults to mm's as the Native Units.
Gerry

2010 Screenset
http://www.thecncwoodworker.com/2010.html

JointCAM Dovetail and Box Joint software
http://www.g-forcecnc.com/jointcam.html
Re: Axis dros off after loading Gcode
« Reply #3 on: December 22, 2016, 12:11:38 PM »
Thanks for the relies. I think Gerry Guessed it. I changed the native units from mm to inch and it seems ok now. I must have missed that setting. ::)
Regards
Charlie M.