Hello Guest it is June 17, 2019, 09:42:02 AM

Author Topic: RFH not working in Plasma  (Read 1625 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
RFH not working in Plasma
« on: December 03, 2016, 05:26:24 PM »
When I was having issues with the M31 faulting I tried to restart a file with a Run From Here. I use it all the time on my mills and lathe but on the plasma it just started moving right away and the code actually started from the beginning rather than stepping through until the RFH point was reached.

I have spent hours trying to work out why, evenmade a new profile from scratch and tested as I went.
Eventually I have found the issue. It seems if there is a macro called from the G Code which contains a G31  then the problem will happen.
Why it does that I have no idea and it is a bit of a PITA as it means I can not use RFH if I need to for any reason.

I think Set Next Line should work, it certainly seems to be fine in simulation but I will have to test out on the Plasma to be sure.

Offline stirling

*
  • *
  •  2,188 2,188
  • UK
    • View Profile
    • www.razordance.co.uk
Re: RFH not working in Plasma
« Reply #1 on: December 04, 2016, 07:35:11 AM »
RFH, set next line, reverse run all = nightmare. IMHO some of the buggyest areas of Mach and VERY version dependent.

What version are you using?

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: RFH not working in Plasma
« Reply #2 on: December 04, 2016, 08:12:11 AM »
Ian, tried about 5 or 6 versions from 037 onwards and all exactly the same.
As said I use RFH all the time on lathe and mill and never an issue, just have to pick your start oint correctly especially when you have toolchangers/turrets.

If I could be bothered I would redo with the separate macros and the G31 in code to see how it behaves but I can't :D  If Set Next Line doesn't work then I will maybe try.

Offline Davek0974

*
  •  2,539 2,539
    • View Profile
    • DD Metal Products Ltd
Re: RFH not working in Plasma
« Reply #3 on: December 04, 2016, 09:55:24 AM »
I have given up trying to rescue stuff with RFH now, there are so many lock-outs on the plasma - anti dive, tip saver, drop arc on fault, plus a couple more that it makes restarting mid-cut practically pointless.

 It takes so long to turn off all the watchdogs that it is usually better to just start over. I think the arc-ok signal is the big stopper, without that the machine will not move at all so it just fires, times out and faults. Some users have an ark-ok manual override button.
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: RFH not working in Plasma
« Reply #4 on: December 04, 2016, 11:54:31 AM »
Dave I reckon most should be salvageable as the ones I have had so far have been on the probing and hence are uncut sections. Also starting again is often not an option, expensive material, lack of more material etc.

When I was doing the round flange in stainless the last day it failed after the first hole, then after the third then I think it cut the last  3 circles but maybe it failed once more, can't quite recall. Anyway I only had one piece of 5mm stainless big enough so I had to make it work and with RFH not working I had to edit the code to miss out the holes already cut, PITA but it worked.

Yesterday I was doing quite a large file, a 400mm x 400mm Santa Claus head in 4mm Alu, halfway through the code called for it to start in a bit that had previously dropped out, why I am not sure yet, not looked at the file closely but I suspect some artifacts in the original drawing. Anyway I tried again with RFH and it failed because of the G31 in macro issue. So again I had to edit the code and it ran the rest fine.

If Set Next Line works then it will work out ok.

As for "lock-outs" then as said all problems so far have been on new starts so not an issue but I do also have the option of pressing a button on my panel which will lock the miniTHC from doing anything until I release it via the button, so that could also be handy.

Offline Davek0974

*
  •  2,539 2,539
    • View Profile
    • DD Metal Products Ltd
Re: RFH not working in Plasma
« Reply #5 on: December 04, 2016, 01:59:27 PM »
Fair-do's, 99% of my stuff is 3mm steel sheet so no biggy if i need to re-run usually.

With most of my work being arty-farty stuff, 99.9% of all errors leading to a stop are caused by tip-ups jamming the torch or dragging the sheet out of position. I started to use the M01 optional stop on the fiddly stuff, its slower but since doing it I have had zero errors so time saved in the long run. I have my post add the M01 before each start and have a screen toggle so i can choose to use it or not :)

Plasma is a blast ;)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Davek0974

*
  •  2,539 2,539
    • View Profile
    • DD Metal Products Ltd
Re: RFH not working in Plasma
« Reply #6 on: December 04, 2016, 04:33:45 PM »
Hood, make sure you have "Ignore M Calls While Loading" checked, might help. ;)
Bridgeport Mill, Mach3 V062, CSMIO-IP/A controller, AC Servo Drives

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: RFH not working in Plasma
« Reply #7 on: December 04, 2016, 05:00:24 PM »
Yes Dave, it is enabled, it is one of the first things I do when setting up a new profile.

Offline Hood

*
  •  25,843 25,843
  • Carnoustie, Scotland
    • View Profile
Re: RFH not working in Plasma
« Reply #8 on: December 05, 2016, 01:31:24 PM »
Set Next Line seemed to work, only got a chance to try it 4 or 5 times but each time it went without a hitch.
Hood