Hello Guest it is October 18, 2019, 11:13:45 PM

Author Topic: Feedhold and CSS  (Read 1057 times)

0 Members and 1 Guest are viewing this topic.

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Feedhold and CSS
« on: August 25, 2016, 03:31:42 PM »
I am having issues with Mach4 and CSS mode when pressing Feedhold.
Mach4 will hold but hangs and can not be resumed. Occasionally the Start button will become active but pressing it does nothing and Mach4 hangs.
 The only way to get out of the situation is to close Mach.
 I have also used the standard lathe profile with default screen and the same happens.

See video here.
https://www.youtube.com/watch?v=LymjO_BSKQM

Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Feedhold and CSS
« Reply #1 on: August 25, 2016, 07:34:31 PM »
Ok I have narrowed this down to one setting, set the Machine Setup Units to metric and FeedHold does not work when in CSS mode.
This may well be linked to the issue that in Metric the surface speed needs to be commanded in cm/min rather than m/min and also the commanded surface speed is actually run at a 20% greater surface speed.

One other thing I found was if you have the Units mode set to Metric then the Active Plane gets set to Y-Z next time you look. Set it back to X-Z and apply and next time you look it is back to Y-Z.
No such problems when the Units mode is set to Inch.

Hood

Offline Hood

*
  •  25,855 25,855
  • Carnoustie, Scotland
    • View Profile
Re: Feedhold and CSS
« Reply #2 on: August 27, 2016, 04:28:20 AM »
I have discovered that CSS and Feedhold also cause Mach to crash when using Inch set up units. The reason I was not seeing it was because I was running metric code and, due to another fault, the spindle speed had been capped due to either the Max rpm set in Mach or the G50 in the code.

I will make  a new subject post with the issues I have found in Mach4 Lathe so as to keep them all together rather than spread out over several subject posts.

Hood