Hello Guest it is June 05, 2020, 07:51:11 PM

Author Topic: Mach3 crashes using LPT but not USB  (Read 1993 times)

0 Members and 1 Guest are viewing this topic.

Offline Rimmel

*
  •  159 159
    • View Profile
Mach3 crashes using LPT but not USB
« on: July 01, 2016, 05:55:12 AM »
Hi, I until recently have been using a UC100 usb notion controller. However due to technical problems have had to go back to using the LPT1 port.

When using the USB I could leave the mahine on for days or weeks without a single problem, howveer since changing to back the LPT1 the WinXP machine crashes (locks up completely) at least once every 24 hours.

Using:
Mach3  062 
LPT1 0x378  ECP mode
25000hz

Anuy ideas?

thanks
Rimmel

Offline Rimmel

*
  •  159 159
    • View Profile
Re: Mach3 crashes using LPT but not USB
« Reply #1 on: July 01, 2016, 06:18:10 AM »
Aditionally - I have changed absolutely nothing else! Literally a switch between USB and LPT1

Offline Tweakie.CNC

*
  • *
  •  8,286 8,286
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 crashes using LPT but not USB
« Reply #2 on: July 01, 2016, 07:11:49 AM »
Perhaps try running the DriverTest (Mach3 folder) and see what kind of results you get.

Tweakie.
KEEP SAFE !

Offline Rimmel

*
  •  159 159
    • View Profile
Re: Mach3 crashes using LPT but not USB
« Reply #3 on: July 01, 2016, 07:51:17 AM »
Hi sorry mean't to say the drivertest comes back perfectly with an excellent result.

I was wondering what the recommended settings were for the LPT port? e.g ECP, EPP using an interrupt or not?

thanks

Offline Tweakie.CNC

*
  • *
  •  8,286 8,286
  • Super Kitty
    • View Profile
    • Tweakie.CNC
Re: Mach3 crashes using LPT but not USB
« Reply #4 on: July 01, 2016, 07:58:45 AM »
Quote
I was wondering what the recommended settings were for the LPT port? e.g ECP, EPP using an interrupt or not?

I think it's a matter of if it works then it works.

Tweakie.
KEEP SAFE !

Offline Hood

*
  •  25,846 25,846
  • Carnoustie, Scotland
    • View Profile
Re: Mach3 crashes using LPT but not USB
« Reply #5 on: July 01, 2016, 08:16:57 AM »
Probably won't help but worth a try I suppose, go to your plugin folder and remove any plugins you do not require, especially the one from the previous controller.
Alternatively rename the plugin folder to something like OldPlugins and then create a new (empty ) folder called Plugins.
Hood

Offline Rimmel

*
  •  159 159
    • View Profile
Re: Mach3 crashes using LPT but not USB
« Reply #6 on: July 01, 2016, 08:26:06 AM »
Hi - I've already removed all the plugins except the Flash-Flashscreen plugin (is that needed?). Never had any apart from the UC100 - and that is gone now

I heard there was a list of compatible PCI LPT cards, anyone know where? I might try adding one.

thanks
« Last Edit: July 01, 2016, 08:31:33 AM by Rimmel »
Re: Mach3 crashes using LPT but not USB
« Reply #7 on: July 05, 2016, 08:30:00 AM »
Check if you lose position, see the axis of the motor and check the angle be correct, make a mark.
If you lose position then is entering noise for the cable paralell, the mach3 then receive alarm of servo for crashing, check his shielding

Because change a parallel port, Which problem technical you have?

Renato